summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-20 15:44:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-20 15:45:38 -0500
commitba7ddc14024195bccdab546b4392ad5531485335 (patch)
treecee2a561d42ac20b4a4b4488c536bf8972e11b0e /dev-libs/leatherman/leatherman-1.12.2.ebuild
parentnet-irc/kvirc: Update usage of python-utils-r1.eclass. (diff)
downloadgentoo-ba7ddc14024195bccdab546b4392ad5531485335.tar.gz
gentoo-ba7ddc14024195bccdab546b4392ad5531485335.tar.bz2
gentoo-ba7ddc14024195bccdab546b4392ad5531485335.zip
dev-libs/leatherman: 1.12.2 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.12.2.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.12.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-1.12.2.ebuild b/dev-libs/leatherman/leatherman-1.12.2.ebuild
new file mode 100644
index 000000000000..37b42a9bc12b
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.12.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+#RESTRICT="!test? ( test )"
+RESTRICT="test" # restricted til we don't need the shared_nowide patch
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.73:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+PATCHES+=( "${FILESDIR}/${PV}"-shared_nowide.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ # vendored boost lib conflicts with boost 1.73 and above
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}