summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-09-18 23:15:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-09-18 23:15:54 -0500
commit4c9844de97efd0de174e238d35f5b056a342b6b9 (patch)
treed6eb717bc1627e0b80991b19753151f929dd9741 /dev-libs/leatherman/leatherman-1.3.0.ebuild
parentapp-admin/ansible: 2.4.0.0 bup (diff)
downloadgentoo-4c9844de97efd0de174e238d35f5b056a342b6b9.tar.gz
gentoo-4c9844de97efd0de174e238d35f5b056a342b6b9.tar.bz2
gentoo-4c9844de97efd0de174e238d35f5b056a342b6b9.zip
dev-libs/leatherman: 1.3.0 bup
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.3.0.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.3.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-1.3.0.ebuild b/dev-libs/leatherman/leatherman-1.3.0.ebuild
new file mode 100644
index 000000000000..73272169b5e2
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22"
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug test"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ default
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}