summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-18 11:14:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-18 11:16:21 -0500
commitcda4eb8f266c588c9ef5884dc92148bca94b45ac (patch)
tree63e657130a1effc1cbddf548b7622d81c10b568f /dev-libs/leatherman
parentdev-python/os-vif: 1.15.2 bump (diff)
downloadgentoo-cda4eb8f266c588c9ef5884dc92148bca94b45ac.tar.gz
gentoo-cda4eb8f266c588c9ef5884dc92148bca94b45ac.tar.bz2
gentoo-cda4eb8f266c588c9ef5884dc92148bca94b45ac.zip
dev-libs/leatherman: 1.7.2 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.7.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index ab2c6eb82832..f3dd51de6ebf 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,2 +1,3 @@
DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
DIST leatherman-1.7.1.tar.gz 814579 BLAKE2B e29e8bbdb58800e35c4c790b833a512ead0e177e22f140f16ef725738336b49afa709976ab6062b7219b705e14a369f31eef0ded26d51240919ace2cba1de739 SHA512 753cb89f7511b6fbc66e49e9c1fc3ecf1a2d61781b65baea763666f49780cf84a20e0a90fb98e7146f6e11555f892cbfb9c3b4f0d84961af7cce7fc4a277a7f1
+DIST leatherman-1.7.2.tar.gz 815088 BLAKE2B d011d2ae8b75c2a6c10c35da0293624fac0a30dac35d5b7f8b2fee264140666996821f60c8f67eeafc351b669c8263d1a95a00ffcdcd28448b36852c607ca69f SHA512 2976e8d56e603ba86bc22217c1c6b729fed62536ea56b0a74afed4d48a85429d2c79900652344e63905448a13d60d29440623980fd770d40e3db729af5d70ef3
diff --git a/dev-libs/leatherman/leatherman-1.7.2.ebuild b/dev-libs/leatherman/leatherman-1.7.2.ebuild
new file mode 100644
index 000000000000..335426971404
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}