summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-26 10:39:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-26 10:54:08 -0500
commitd3f50f545abf1d908d807cf4478f73321a978123 (patch)
tree59540ad20b9a7a511078c284b53ea35d479a6c68 /dev-libs/leatherman
parentnet-wireless/kismetmobiledashboard: add tag release (diff)
downloadgentoo-d3f50f545abf1d908d807cf4478f73321a978123.tar.gz
gentoo-d3f50f545abf1d908d807cf4478f73321a978123.tar.bz2
gentoo-d3f50f545abf1d908d807cf4478f73321a978123.zip
dev-libs/leatherman: 1.6.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.6.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index e1a5f5dbafc7..976499231e97 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,2 +1,3 @@
DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
DIST leatherman-1.5.4.tar.gz 814395 BLAKE2B 251cacad45e1571d54e7b78201bb0b3578d983022267bfd3438e921f93ba466995629759d9657c71938a5866fc13d1b70dabe2f3a43137ef52164f67da3a8aa5 SHA512 67a3a0a946024d0cee44ccb314d13abb3df83d7c7d0bfe58d5e966d57ef26240dc011a8e6865f017674a00043429379ae9e033a9197c4173c3fa173918d0b0f9
+DIST leatherman-1.6.0.tar.gz 814463 BLAKE2B 1c990c261ded1fd32bb5b1912f84a4bef8ac3ccfae9172e0496f90283e1a2ac210bf9dc1c7e88bcb8776798674d93c1313359135051b4c7f023e1e3080104e2e SHA512 d0d22b60db2c164183268d29fe1bc1ee9ed16797d38174849eaa74841f801869d038e5672664aae89517487811a70f689a345a2c87d3a2f0a04d55214e7f9eaa
diff --git a/dev-libs/leatherman/leatherman-1.6.0.ebuild b/dev-libs/leatherman/leatherman-1.6.0.ebuild
new file mode 100644
index 000000000000..335426971404
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}