summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-03-27 10:06:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-03-27 10:10:20 -0500
commitd79a965034898e508ef925f2e0b52efad234b117 (patch)
tree6d021f92c67dd99a9cfcfcd810d0ec8f4b7306ef /dev-libs/leatherman
parentdev-python/cgroup-utils: 0.8 + EAPI 7 + tests + py3[78] (diff)
downloadgentoo-d79a965034898e508ef925f2e0b52efad234b117.tar.gz
gentoo-d79a965034898e508ef925f2e0b52efad234b117.tar.bz2
gentoo-d79a965034898e508ef925f2e0b52efad234b117.zip
dev-libs/leatherman: 1.11.0 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.11.0.ebuild58
-rw-r--r--dev-libs/leatherman/metadata.xml3
3 files changed, 59 insertions, 3 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index af977d384986..65be3db4fe8d 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,2 +1,3 @@
DIST leatherman-1.10.0.tar.gz 815748 BLAKE2B de4ff5e60fbdd80a247498e831203aad7efbb8857c8d307f0ac2c2f19fdf5ba3d953cb4910db0267a303b13bd54bf763034ca8b342a820fa8e28a2c013267149 SHA512 66d630980db7a8e5eb394c07d4a8221169271af1eabfceec107343b6c3afddde04c7cadd72b0d8b89327c46b7127dfdf01fa54938a3bf1b44892020a4e7ea209
+DIST leatherman-1.11.0.tar.gz 815946 BLAKE2B 73afb7c517ea93d0c3dc1c88adb3e5041c764bbfb223357b14a6a3f864ff614d178e7a71293eb533f09013fe3f64d5afe40c9404882d2fe6836da7322e869d8f SHA512 0cbc558ba6976d4f14947efbc59e2ebc306a8c7e4590a22fa2e2f044b37ffd8804dbabaf96c599c47394fd9379f2de1330ce5282237b5009730d8d3b87349ae5
DIST leatherman-1.3.0.tar.gz 434229 BLAKE2B e0c19bca2378afc4928554ac0862543504ba725aadc6cffd78220f7f7f1b725cad960fc6d9fdd2d54a43c233b35959ebcb9c71d1191a5535703599fa32e3301e SHA512 5e06be7add652f69b0d4a8d778e33dfb68183c4d598217cc6542d2431f7984f0af989c27bd69e89b77ab03d6dd2adab9d70f68cd87dae20d8e24ae05923fbe9b
diff --git a/dev-libs/leatherman/leatherman-1.11.0.ebuild b/dev-libs/leatherman/leatherman-1.11.0.ebuild
new file mode 100644
index 000000000000..aef4cd923095
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.11.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/dev-libs/leatherman/metadata.xml b/dev-libs/leatherman/metadata.xml
index 942d1e749b9c..7289abdb42fb 100644
--- a/dev-libs/leatherman/metadata.xml
+++ b/dev-libs/leatherman/metadata.xml
@@ -8,7 +8,4 @@
<upstream>
<remote-id type="github">puppetlabs/leatherman</remote-id>
</upstream>
- <longdescription lang="en">
- A set of C++ Libraries.
- </longdescription>
</pkgmetadata>