summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-06-16 02:33:04 +0200
committerDavid Seifert <soap@gentoo.org>2018-06-17 22:34:25 +0200
commit0439d4131fca943e7854bc391cb2b3d592b40060 (patch)
tree7151b275e3260b657db8878031e84be1f15a36d5 /dev-libs/leveldb/leveldb-1.10.0-r1.ebuild
parentdev-libs/leveldb: bump to 1.20, sub-slot to avoid ABI breakage (diff)
downloadgentoo-0439d4131fca943e7854bc391cb2b3d592b40060.tar.gz
gentoo-0439d4131fca943e7854bc391cb2b3d592b40060.tar.bz2
gentoo-0439d4131fca943e7854bc391cb2b3d592b40060.zip
dev-libs/leveldb: remove old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/leveldb/leveldb-1.10.0-r1.ebuild')
-rw-r--r--dev-libs/leveldb/leveldb-1.10.0-r1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-libs/leveldb/leveldb-1.10.0-r1.ebuild b/dev-libs/leveldb/leveldb-1.10.0-r1.ebuild
deleted file mode 100644
index 9c017847de4c..000000000000
--- a/dev-libs/leveldb/leveldb-1.10.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="a fast key-value storage library written at Google"
-HOMEPAGE="https://github.com/google/leveldb"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+snappy static-libs +tcmalloc"
-
-DEPEND="tcmalloc? ( dev-util/google-perftools )
- snappy? (
- app-arch/snappy
- static-libs? ( app-arch/snappy[static-libs] )
- )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.9.0-forwardcompat.patch
-}
-
-src_configure() {
- # These vars all get picked up by build_detect_platform
- # which the Makefile runs for us automatically.
- tc-export AR CC CXX
- export OPT="-DNDEBUG ${CPPFLAGS}"
- # Probably needs more filling out
- export TARGET_OS
- case ${CHOST} in
- *) TARGET_OS="Linux";;
- esac
- export USE_SNAPPY=$(usex snappy)
- export USE_TCMALLOC=no
-}
-
-src_compile() {
- emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/include
- doins -r include/* helpers/memenv/memenv.h
- dolib.so libleveldb*$(get_libname)*
- use static-libs && dolib.a libleveldb.a
- dolib.a libmemenv.a
-}