summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarshall Brewer (Gentoo Key) <tomboy64@sina.cn>2016-04-12 22:11:43 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-28 22:12:20 +0800
commit987453ea66b051c13f59a5e32389dfca099cddb6 (patch)
tree85111b99a776f3056a580cf9c0c0a61d9605af37 /dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild
parentapp-admin/puppet: fix patch for bug 581428 (diff)
downloadgentoo-987453ea66b051c13f59a5e32389dfca099cddb6.tar.gz
gentoo-987453ea66b051c13f59a5e32389dfca099cddb6.tar.bz2
gentoo-987453ea66b051c13f59a5e32389dfca099cddb6.zip
dev-libs/libarcus: initial ebuild, version 1.0.0_pre20160307
Closes: https://github.com/gentoo/gentoo/pull/1298 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild')
-rw-r--r--dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild b/dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild
new file mode 100644
index 000000000000..6f1f571a2278
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-1.0.0_pre20160307.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+inherit cmake-utils python-single-r1
+
+MY_PN="libArcus"
+COMMIT="1db8a8e57dbf0d68d9e9f85ef9022b8eae17c9ec"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/2"
+IUSE="examples python static-libs"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/sip[${PYTHON_USEDEP}]
+ >=dev-libs/protobuf-3:=
+ >=dev-python/protobuf-python-3:*[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_PN}-${COMMIT}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-fix-install-paths.patch" )
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+ use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}