summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 15:55:16 +0300
committerAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 15:55:16 +0300
commit178c852f907a6d3a2363d84822d01bd908759382 (patch)
tree1436e76977f763d7909ea6671cea89a1c98ec1b2 /dev-libs/libarcus/libarcus-2.6.0.ebuild
parentdev-libs/libarcus: Set minimal python version to 3.5 (diff)
downloadgentoo-178c852f907a6d3a2363d84822d01bd908759382.tar.gz
gentoo-178c852f907a6d3a2363d84822d01bd908759382.tar.bz2
gentoo-178c852f907a6d3a2363d84822d01bd908759382.zip
dev-libs/libarcus: Clean up old
Closes: https://bugs.gentoo.org/616170 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libarcus/libarcus-2.6.0.ebuild')
-rw-r--r--dev-libs/libarcus/libarcus-2.6.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-libs/libarcus/libarcus-2.6.0.ebuild b/dev-libs/libarcus/libarcus-2.6.0.ebuild
deleted file mode 100644
index 59d80b0d81b0..000000000000
--- a/dev-libs/libarcus/libarcus-2.6.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
-inherit cmake-utils python-single-r1
-
-MY_PN="libArcus"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libArcus"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="AGPL-3+"
-SLOT="0/2"
-IUSE="examples python static-libs"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/sip[${PYTHON_USEDEP}]
- >=dev-libs/protobuf-3:=
- >=dev-python/protobuf-python-3:*[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_PN}-${PV}"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_PYTHON=$(usex python ON OFF)
- -DBUILD_EXAMPLES=$(usex examples ON OFF)
- -DBUILD_STATIC=$(usex static-libs ON OFF)
- )
- use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
- cmake-utils_src_configure
-}