summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 15:51:36 +0300
committerAlexey Shvetsov <alexxy@omrb.pnpi.spb.ru>2018-06-14 15:51:36 +0300
commit1609762963b6114ad3249710b30e396585242240 (patch)
tree218fd47ec2f69e42967a8758d49e79791f4f6342 /dev-libs/libarcus/libarcus-3.3.0.ebuild
parentsci-chemistry/gromacs: Version bump (diff)
downloadgentoo-1609762963b6114ad3249710b30e396585242240.tar.gz
gentoo-1609762963b6114ad3249710b30e396585242240.tar.bz2
gentoo-1609762963b6114ad3249710b30e396585242240.zip
dev-libs/libarcus: Version bump
Closes: https://bugs.gentoo.org/648130 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libarcus/libarcus-3.3.0.ebuild')
-rw-r--r--dev-libs/libarcus/libarcus-3.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libarcus/libarcus-3.3.0.ebuild b/dev-libs/libarcus/libarcus-3.3.0.ebuild
new file mode 100644
index 000000000000..93172e0b6411
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-libs/protobuf
+ python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+ use python && mycmakeargs+=( -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}