summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-09 09:57:24 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-09 09:57:51 +0100
commit24dab8a4443ded9b2f48f38a30f3c44524c9f5ac (patch)
tree8d636fad862fcd1239b8aea458b6c3f88bf37023 /dev-libs/libassuan/libassuan-2.5.3.ebuild
parentsys-apps/util-linux: Bump to version 2.35_rc2. Removed old (diff)
downloadgentoo-24dab8a4443ded9b2f48f38a30f3c44524c9f5ac.tar.gz
gentoo-24dab8a4443ded9b2f48f38a30f3c44524c9f5ac.tar.bz2
gentoo-24dab8a4443ded9b2f48f38a30f3c44524c9f5ac.zip
dev-libs/libassuan: Simplified ebuilds a bit
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libassuan/libassuan-2.5.3.ebuild')
-rw-r--r--dev-libs/libassuan/libassuan-2.5.3.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/libassuan/libassuan-2.5.3.ebuild b/dev-libs/libassuan/libassuan-2.5.3.ebuild
index 8a00919e7748..aca104db0f04 100644
--- a/dev-libs/libassuan/libassuan-2.5.3.ebuild
+++ b/dev-libs/libassuan/libassuan-2.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,10 +33,12 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable static-libs static) \
- GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
- $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {