summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-22 22:30:59 +0000
committerSam James <sam@gentoo.org>2022-01-22 22:31:01 +0000
commit2f7b5dee4b0f2470e52792ce352006664b9dc071 (patch)
treeea2f956870f3b88e46aeab0492529ea75545ddf1 /dev-libs/libbsd
parentautotools.eclass: update for autoconf 2.71 (diff)
downloadgentoo-2f7b5dee4b0f2470e52792ce352006664b9dc071.tar.gz
gentoo-2f7b5dee4b0f2470e52792ce352006664b9dc071.tar.bz2
gentoo-2f7b5dee4b0f2470e52792ce352006664b9dc071.zip
dev-libs/libbsd: add 0.11.4
Drop obsolete pkg_setup hack from 2011 (at point of package import!) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.11.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index b181adc564fa..6d0fb03107da 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1 +1,2 @@
DIST libbsd-0.11.3.tar.xz 399712 BLAKE2B 1af04b8fcbc0bfa59fba549639d61a33ac934fe7ee42b506d1b0452e0b836b0bfdd3d8739de90465be46fe6a9d326a2d11bcf72280aa19ccba81db5da6d63d89 SHA512 a7015ea1ffa3766b1a4690526a25231898ad8275149b31fb6801082450172249997c36165626d101ffce53b59767a46676eebc0806426922fe4e773a0376c1f5
+DIST libbsd-0.11.4.tar.xz 409148 BLAKE2B f6d71ac7b823cd8e46dbdefa044bdd6a026f7b1f4f5dcc6d7b9ad00851e1dff783ce55bdcfdea0896b98ed1f283df1a9baeaa55ca426c6653511d00e33fa63dc SHA512 59b903389529ff69e8c4644483cc991ae1e574384ef8ea37b4552766cb72fdc254b1e64edf6d4594c98b520cd9fef8543fe002b2fe04da7a25750809d040b995
diff --git a/dev-libs/libbsd/libbsd-0.11.4.ebuild b/dev-libs/libbsd/libbsd-0.11.4.ebuild
new file mode 100644
index 000000000000..55d75e728bd8
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.11.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.17
+"
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}