summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-06 19:38:53 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-06 19:38:53 +0100
commitd90691b7edf65e7a9b7bbdcc43142c6580252051 (patch)
treefdec32ebab213d8f34456287a927da991e928acd /dev-libs/libbsd
parentapp-crypt/acme: Add version 0.1.0 (diff)
downloadgentoo-d90691b7edf65e7a9b7bbdcc43142c6580252051.tar.gz
gentoo-d90691b7edf65e7a9b7bbdcc43142c6580252051.tar.bz2
gentoo-d90691b7edf65e7a9b7bbdcc43142c6580252051.zip
dev-libs/libbsd: Version bump to 0.8.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 8ef159dd96fd..257d9c69a282 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1 +1,2 @@
DIST libbsd-0.7.0.tar.xz 322908 SHA256 0f3b0e17e5c34c038126e0a04351b11e23c6101a7d0ce3beeab29bb6415c10bb SHA512 2c4c8fb2ae7fb5e5aab90f7a59a679220922dfeeaf0d54f80976914fcd507171bb9359f0837c32499e63a0f3e9342c9dcd387a466b359d20e3790ddc8ca17cea WHIRLPOOL 06083651f5678362d3422f96e59d30d8010493f9d1c8c43a94f7ab310daead491c70bce7838cc8302cb448e4a8fa99c7456f0ba9a3b411b292829ba949712b59
+DIST libbsd-0.8.0.tar.xz 342016 SHA256 fbb732084bd960e4c78b688aac875be98e290cc6fe462b2ff8ee946a6473e38c SHA512 a2235cde4d24ce55b0ad16eb12b421c3b35ea5ca35cd8dbf25dd9a01f6a12c737b877c8e1dd344d4cfdfbbbc872d17424e3b9944993395d752fc0b80ead7d06a WHIRLPOOL 96e429eb7b44db5bce2def2ab7ef1a773d8dc630deb636e422e96c6521b61f37082b4889e564409e3af779d8d93a85cb54079a15a1415073fd65169a91593ad1
diff --git a/dev-libs/libbsd/libbsd-0.8.0.ebuild b/dev-libs/libbsd/libbsd-0.8.0.ebuild
new file mode 100644
index 000000000000..ce72644d5283
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}