summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-06-26 16:27:48 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-01 21:23:15 +0200
commitaf55e020ed97e6658d61d57ec9f1065eaf7d8bab (patch)
tree1aec4b21e998aab2e12da7cd33ade37c30f9c581 /dev-libs/libbson/libbson-1.11.0.ebuild
parentsys-cluster/keepalived: bump to 2.0.6 (diff)
downloadgentoo-af55e020ed97e6658d61d57ec9f1065eaf7d8bab.tar.gz
gentoo-af55e020ed97e6658d61d57ec9f1065eaf7d8bab.tar.bz2
gentoo-af55e020ed97e6658d61d57ec9f1065eaf7d8bab.zip
dev-libs/libbson: bump to 1.11.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9171
Diffstat (limited to 'dev-libs/libbson/libbson-1.11.0.ebuild')
-rw-r--r--dev-libs/libbson/libbson-1.11.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libbson/libbson-1.11.0.ebuild b/dev-libs/libbson/libbson-1.11.0.ebuild
new file mode 100644
index 000000000000..e229e5ac1bdd
--- /dev/null
+++ b/dev-libs/libbson/libbson-1.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Library routines related to building,parsing and iterating BSON documents"
+HOMEPAGE="https://github.com/mongodb/mongo-c-driver/tree/master/src/libbson"
+SRC_URI="https://github.com/mongodb/mongo-c-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="examples static-libs"
+
+DEPEND="dev-python/sphinx"
+
+S="${WORKDIR}/mongo-c-driver-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BSON=ON
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_MAN_PAGES=ON
+ -DENABLE_MONGOC=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_STATIC="$(usex static-libs ON OFF)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use examples; then
+ docinto examples
+ dodoc src/libbson/examples/*.c
+ fi
+
+ cmake-utils_src_install
+}