summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2017-10-05 19:01:09 +0200
committerDaniel Pielmeier <billie@gentoo.org>2017-10-05 19:01:09 +0200
commit769de7b310f3088222f038050e29a75abdb290bc (patch)
treec8d9dcedfa35f701e5a9b280467966f055500d06 /dev-libs/libburn/libburn-1.4.8.ebuild
parentsys-libs/glibc: Another revbump, patchset 11. Bug 632556, sorry about that. (diff)
downloadgentoo-769de7b310f3088222f038050e29a75abdb290bc.tar.gz
gentoo-769de7b310f3088222f038050e29a75abdb290bc.tar.bz2
gentoo-769de7b310f3088222f038050e29a75abdb290bc.zip
dev-libs/libburn: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libburn/libburn-1.4.8.ebuild')
-rw-r--r--dev-libs/libburn/libburn-1.4.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libburn/libburn-1.4.8.ebuild b/dev-libs/libburn/libburn-1.4.8.ebuild
new file mode 100644
index 000000000000..930793107d08
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.4.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cdio debug static-libs track-src-odirect"
+
+RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable track-src-odirect) \
+ --enable-pkg-check-modules \
+ $(use_enable cdio libcdio) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dodoc cdrskin/cdrskin_eng.html
+
+ find "${D}" -name '*.la' -delete || die
+}