summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-09-21 10:35:39 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-09-21 10:35:56 -0700
commitc8bccabe975025e7aed3871f00492c8a687b4cd7 (patch)
treed6e1e65f2bae95e84f6aa38caa79a080c39ee9dd /dev-libs/libcbor
parentmedia-plugins/kodi-pvr-nextpvr: fix dependency; should be tinyxml2 (diff)
downloadgentoo-c8bccabe975025e7aed3871f00492c8a687b4cd7.tar.gz
gentoo-c8bccabe975025e7aed3871f00492c8a687b4cd7.tar.bz2
gentoo-c8bccabe975025e7aed3871f00492c8a687b4cd7.zip
dev-libs/libcbor-0.8.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/libcbor')
-rw-r--r--dev-libs/libcbor/Manifest1
-rw-r--r--dev-libs/libcbor/libcbor-0.8.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/libcbor/Manifest b/dev-libs/libcbor/Manifest
index 5f4226e60551..fa2e5872c046 100644
--- a/dev-libs/libcbor/Manifest
+++ b/dev-libs/libcbor/Manifest
@@ -2,3 +2,4 @@ DIST libcbor-0.5.0.tar.gz 719348 BLAKE2B 57e15e648159e7858d9d57a8b4cb7f3682f8153
DIST libcbor-0.6.0.tar.gz 262622 BLAKE2B 2d3bc10bdb69c9205430718a8f2652672a8fa580ba7951c4012bdc8b502a9d6dcb26f398740f5fd35dfe0634f8e3d8ddf7eff5b9ec35c95cdc5383e2dce9f0ab SHA512 6adbb32780d428140388295c5d740bd77b0ae7b21e3f73629ba56a3aa4e4ee5dbb715454061b0f6f67f2b19ea8366e0e5c24f4ffb1ba629afcb7a776a15045f7
DIST libcbor-0.6.1.tar.gz 263486 BLAKE2B 9a2415c1dde7ed611075c3b03ea1d8ab63bcb00dfc0cae3d7a3bb225b6fbee2a8f576b1f0f97eb6f0cf14c1a6e9df1c77f69320bac041287b0dec37c073f8b85 SHA512 dc9bb7d18b934fe33faabe30010425cb272d7e135f3bf233554bc934b1701f85c7b662e0d5a6a1921c21cd46acb4393600e9adc05b09d1b2a8e3c92ca9d7e4e8
DIST libcbor-0.7.0.tar.gz 266323 BLAKE2B 76f93d3199e703c4167aeed262da7ba78d1df82e081754609391572b89f216efba0c54511d4021049fc6c62ab01b08835f02a58bbf226d973174b37eff087761 SHA512 4e2ed55ef17b8b77f82d780b1ee998d0342b67e6beabc24795117e5e222549640fe7fd261c8e78524d6489d03f7f5aa46b987709790a81f93e4d7409c32fecda
+DIST libcbor-0.8.0.tar.gz 267044 BLAKE2B e8548e7351984ebdcbeb5f13a7ca35412c3f3f05e2a44a5438d57b90bdcdc51f5265953163106f90ade911a96af665956ebeba7ed1c48cf207acf6d683af5606 SHA512 694d2d3a78d80072f96e0afb73590ca1f3572e41d2117330ef4313ed06271743b048d3ba3259c6ffe9a802d5e441379d0e54787d1d42fed08dc81ac4f06c6dbc
diff --git a/dev-libs/libcbor/libcbor-0.8.0.ebuild b/dev-libs/libcbor/libcbor-0.8.0.ebuild
new file mode 100644
index 000000000000..07dbf2319eae
--- /dev/null
+++ b/dev-libs/libcbor/libcbor-0.8.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1 cmake-utils
+
+DESCRIPTION="CBOR protocol implementation for C and others"
+HOMEPAGE="https://github.com/pjk/libcbor"
+SRC_URI="https://github.com/PJK/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+custom-alloc doc test"
+
+BDEPEND="
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/breathe[${PYTHON_USEDEP}]
+ ')
+ )
+ test? ( dev-util/cmocka )
+"
+
+RESTRICT="!test? ( test )"
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+python_check_deps() {
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/breathe[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=Release
+ -DCBOR_CUSTOM_ALLOC=$(usex custom-alloc 'ON' 'OFF')
+ -DWITH_TESTS=$(usex test 'ON' 'OFF')
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ pushd doc >/dev/null || die
+ emake html man
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ dodoc -r doc/build/html
+ doman doc/build/man/*
+ fi
+}