summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 19:48:30 +0100
committerSam James <sam@gentoo.org>2022-04-17 19:59:41 +0100
commit15a9f670d86588faf649fe42b55836d3d04ade65 (patch)
treede506adbfd6a954ca9be6f372973834b44f2b5d8 /dev-libs/libcec
parentdev-libs/keystone: drop 0.9.2 (diff)
downloadgentoo-15a9f670d86588faf649fe42b55836d3d04ade65.tar.gz
gentoo-15a9f670d86588faf649fe42b55836d3d04ade65.tar.bz2
gentoo-15a9f670d86588faf649fe42b55836d3d04ade65.zip
dev-libs/libcec: drop 4.0.4-r1, 4.0.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/Manifest2
-rw-r--r--dev-libs/libcec/libcec-4.0.4-r1.ebuild78
-rw-r--r--dev-libs/libcec/libcec-4.0.7.ebuild123
3 files changed, 0 insertions, 203 deletions
diff --git a/dev-libs/libcec/Manifest b/dev-libs/libcec/Manifest
index e40cd603a8c8..a67ecd5cbf8e 100644
--- a/dev-libs/libcec/Manifest
+++ b/dev-libs/libcec/Manifest
@@ -1,3 +1 @@
-DIST libcec-4.0.4.tar.gz 344976 BLAKE2B ce88730ee6e9f57a3f874dd47343e8bb12bd9d3644b58703f0b797bfe656fa25461e6847db4023fec92d9e9740f0e58b59a203258d39d8883b8ae9cde147f455 SHA512 8991ba96fe9a87e5e1f63ff87f77fc0fc3b735c537e2ee6cb004fdc264d75cecd043e39b49cf9e64aeadd24bb1fb57911d9c4bd6c494d9ba4035d7320c268116
-DIST libcec-4.0.7.tar.gz 355249 BLAKE2B 5f742364804d0d10cfcd71635645d33c3dfde200e79332470d2b5b2e64966834a0604d4684ad5919a00aaf60f05f4dbbbc9ce13a0dcf0ba4fa11d1f6a0391673 SHA512 424540a45f9cae3d5dcccc615d487c45033f9cdeb665b8176832495597e2cd58ef7681e13b52f6a32f8a40e1146c04a1a383f5785ea1e731c5c517a9a7843a81
DIST libcec-6.0.2.tar.gz 355807 BLAKE2B 007530d839493355f283992a4390550d6ddd432977d7489c17087f7e5bb6f503c35e967ed6a620d55e2e7c25ce10814f360d146a28b860cdcdd108fae152f896 SHA512 c16ac268e67b01d4e35fad644e5927e1d9fc7bcaeff698ac5f0eadd31ec63a0bef2a2b2bc37860d1571e1e0cdc55911c2de468c661c7c7ae1d492f80188035cb
diff --git a/dev-libs/libcec/libcec-4.0.4-r1.ebuild b/dev-libs/libcec/libcec-4.0.4-r1.ebuild
deleted file mode 100644
index 7042dfd820b5..000000000000
--- a/dev-libs/libcec/libcec-4.0.4-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-MY_PV=${PV/_p/-}
-MY_P=${PN}-${MY_PV}
-
-inherit cmake linux-info python-single-r1 toolchain-funcs
-
-DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
-HOMEPAGE="http://libcec.pulse-eight.com"
-SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="cubox exynos python raspberry-pi +xrandr"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="virtual/udev
- >=dev-libs/libplatform-2.0.0
- sys-libs/ncurses:=
- raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
- xrandr? ( x11-libs/libXrandr )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- virtual/pkgconfig"
-
-CONFIG_CHECK="~USB_ACM"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-pkg_pretend() {
- linux-info_pkg_setup
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Do not hardcode the python libpath #577612
- sed -i \
- -e '/DESTINATION/s:lib/python${PYTHON_VERSION}/dist-packages:${PYTHON_SITEDIR}:' \
- src/libcec/cmake/CheckPlatformSupport.cmake || die
-
- use python || cmake_comment_add_subdirectory "src/pyCecClient"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSKIP_PYTHON_WRAPPER=$(usex !python)
- -DHAVE_EXYNOS_API=$(usex exynos)
- -DHAVE_TDA995X_API=$(usex cubox)
- -DHAVE_RPI_API=$(usex raspberry-pi)
- )
-
- # raspberrypi-userland itself does not provide .pc file so using
- # bcm_host.pc instead
- use raspberry-pi && mycmakeargs+=(
- -DRPI_INCLUDE_DIR=$( $(tc-getPKG_CONFIG) --variable=includedir bcm_host) \
- -DRPI_LIB_DIR=$( $(tc-getPKG_CONFIG) --variable=libdir bcm_host)
- )
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- elog "You will need to ensure the user running your CEC client has"
- elog "read/write access to the device. You can ensure this by adding"
- elog "them to the uucp group"
-}
diff --git a/dev-libs/libcec/libcec-4.0.7.ebuild b/dev-libs/libcec/libcec-4.0.7.ebuild
deleted file mode 100644
index f3723dd903c0..000000000000
--- a/dev-libs/libcec/libcec-4.0.7.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-MY_PV=${PV/_p/-}
-MY_P=${PN}-${MY_PV}
-
-inherit cmake linux-info python-single-r1 toolchain-funcs
-
-DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
-HOMEPAGE="http://libcec.pulse-eight.com"
-SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${MY_P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="cubox exynos python raspberry-pi kernel-cec tools +xrandr udev"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="udev? ( virtual/udev )
- >=dev-libs/libplatform-2.0.0
- tools? ( sys-libs/ncurses:= )
- raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
- xrandr? ( x11-libs/libXrandr )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )"
-
-BDEPEND="virtual/pkgconfig"
-
-CONFIG_CHECK="~USB_ACM"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.0.7-no-override-udev.patch"
- )
-
-pkg_pretend() {
- use udev || CONFIG_CHECK+=" ~SYSFS"
- ERROR_SYSFS="When using libcec build without udev, kernel config option CONFIG_SYSFS is required to automatically detect P8 USB-CEC adapter port number"
-
- linux-info_pkg_setup
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- # Do not hardcode the python libpath #577612
- sed -i \
- -e '/DESTINATION/s:"lib/python${PYTHON_VERSION}/${PYTHON_PKG_DIR}":${PYTHON_SITEDIR}:' \
- src/libcec/cmake/CheckPlatformSupport.cmake || die
-
- sed -Ee 's|[ ~]?#DIST#;?||g' debian/changelog.in > ChangeLog || die
-
- (use tools && use python) || cmake_comment_add_subdirectory "src/pyCecClient"
-
- if ! use tools; then
- cmake_comment_add_subdirectory "src/cec-client"
- cmake_comment_add_subdirectory "src/cecc-client"
- sed -i -Ee 's|add_dependencies\(cecc?-client cec\)|#DO NOT BUILD \0|' \
- CMakeLists.txt || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHAVE_LINUX_API=$(usex kernel-cec ON OFF)
- -DHAVE_LIBUDEV=$(usex udev ON OFF)
- -DSKIP_PYTHON_WRAPPER=$(usex python OFF ON)
- -DHAVE_EXYNOS_API=$(usex exynos ON OFF)
- -DHAVE_TDA995X_API=$(usex cubox ON OFF)
- -DHAVE_RPI_API=$(usex raspberry-pi ON OFF)
- )
-
- if linux_config_exists && linux_chkconfig_present SYSFS; then
- mycmakeargs+=( -DHAVE_P8_USB_DETECT=ON )
- fi
-
- # raspberrypi-userland itself does not provide .pc file so using
- # bcm_host.pc instead
- use raspberry-pi && mycmakeargs+=(
- -DRPI_INCLUDE_DIR=$( $(tc-getPKG_CONFIG) --variable=includedir bcm_host) \
- -DRPI_LIB_DIR=$( $(tc-getPKG_CONFIG) --variable=libdir bcm_host)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use udev; then
- cp "${S}/debian/pulse-eight-usb-cec.udev" \
- "${BUILD_DIR}/65-pulse-eight-usb-cec.udev" || die
- fi
-}
-
-src_install() {
- cmake_src_install
-
- use python && python_optimize "${D}$(python_get_sitedir)"
-
- use tools && doman debian/cec-client.1
-
- if use udev; then
- insinto /lib/udev/rules.d
- doins "${BUILD_DIR}/65-pulse-eight-usb-cec.udev"
- fi
-}
-
-pkg_postinst() {
- elog "You will need to ensure the user running your CEC client has"
- elog "read/write access to the device. You can ensure this by adding"
- elog "them to the uucp group"
-}