summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-06 08:31:50 +0000
committerSam James <sam@gentoo.org>2020-11-06 08:32:57 +0000
commit4e008d05af9c1c094345588a5454bc72f2248929 (patch)
tree3f4fa578f41bdd851a236ea91e7fe2d3bbb9ec3f /dev-libs/libcec
parentdev-libs/libcec: cmake-utils -> cmake (diff)
downloadgentoo-4e008d05af9c1c094345588a5454bc72f2248929.tar.gz
gentoo-4e008d05af9c1c094345588a5454bc72f2248929.tar.bz2
gentoo-4e008d05af9c1c094345588a5454bc72f2248929.zip
dev-libs/libcec: cleanup old
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/Manifest1
-rw-r--r--dev-libs/libcec/libcec-4.0.2-r2.ebuild83
2 files changed, 0 insertions, 84 deletions
diff --git a/dev-libs/libcec/Manifest b/dev-libs/libcec/Manifest
index 77048113bece..e40cd603a8c8 100644
--- a/dev-libs/libcec/Manifest
+++ b/dev-libs/libcec/Manifest
@@ -1,4 +1,3 @@
-DIST libcec-4.0.2.tar.gz 334995 BLAKE2B bdbebeb339ce39f2f740805c4c627cc5190cc0dd57d0d87e3d3aa4ba8feeba103336d035fb8b282358f2e08fa470111be43df4df48870be0e9aa93f35434d0ef SHA512 7bb80965cd1bef713f59bff136dc4a7f1172c4a9bdb8e2f59c6bcc5b74110848c0b2912263280ea68177908a688127e8d7208fc43ce6e65d589343b85395a0bb
DIST libcec-4.0.4.tar.gz 344976 BLAKE2B ce88730ee6e9f57a3f874dd47343e8bb12bd9d3644b58703f0b797bfe656fa25461e6847db4023fec92d9e9740f0e58b59a203258d39d8883b8ae9cde147f455 SHA512 8991ba96fe9a87e5e1f63ff87f77fc0fc3b735c537e2ee6cb004fdc264d75cecd043e39b49cf9e64aeadd24bb1fb57911d9c4bd6c494d9ba4035d7320c268116
DIST libcec-4.0.7.tar.gz 355249 BLAKE2B 5f742364804d0d10cfcd71635645d33c3dfde200e79332470d2b5b2e64966834a0604d4684ad5919a00aaf60f05f4dbbbc9ce13a0dcf0ba4fa11d1f6a0391673 SHA512 424540a45f9cae3d5dcccc615d487c45033f9cdeb665b8176832495597e2cd58ef7681e13b52f6a32f8a40e1146c04a1a383f5785ea1e731c5c517a9a7843a81
DIST libcec-6.0.2.tar.gz 355807 BLAKE2B 007530d839493355f283992a4390550d6ddd432977d7489c17087f7e5bb6f503c35e967ed6a620d55e2e7c25ce10814f360d146a28b860cdcdd108fae152f896 SHA512 c16ac268e67b01d4e35fad644e5927e1d9fc7bcaeff698ac5f0eadd31ec63a0bef2a2b2bc37860d1571e1e0cdc55911c2de468c661c7c7ae1d492f80188035cb
diff --git a/dev-libs/libcec/libcec-4.0.2-r2.ebuild b/dev-libs/libcec/libcec-4.0.2-r2.ebuild
deleted file mode 100644
index 7a242dcd5187..000000000000
--- a/dev-libs/libcec/libcec-4.0.2-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-MY_PV=${PV/_p/-}
-MY_P=${PN}-${MY_PV}
-
-inherit cmake-utils linux-info python-single-r1 toolchain-funcs
-
-DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
-HOMEPAGE="http://libcec.pulse-eight.com"
-SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="cubox exynos python raspberry-pi +xrandr"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="virtual/udev
- >=dev-libs/libplatform-2.0.0
- sys-libs/ncurses:=
- raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
- xrandr? ( x11-libs/libXrandr )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- virtual/pkgconfig"
-
-CONFIG_CHECK="~USB_ACM"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-PATCHES=( "${FILESDIR}/${P}-no-tinfo.patch" )
-
-pkg_pretend() {
- linux-info_pkg_setup
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # Do not hardcode the python libpath #577612
- sed -i \
- -e '/DESTINATION/s:lib/python${PYTHON_VERSION}/dist-packages:${PYTHON_SITEDIR}:' \
- src/libcec/cmake/CheckPlatformSupport.cmake || die
-
- use python || cmake_comment_add_subdirectory "src/pyCecClient"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DSKIP_PYTHON_WRAPPER=$(usex !python)
- -DHAVE_EXYNOS_API=$(usex exynos)
- -DHAVE_TDA995X_API=$(usex cubox)
- -DHAVE_RPI_API=$(usex raspberry-pi)
- )
- use python && mycmakeargs+=(
- -DPYTHON_SITEDIR="$(python_get_sitedir)"
- )
-
- # raspberrypi-userland itself does not provide .pc file so using
- # bcm_host.pc instead
- use raspberry-pi && mycmakeargs+=(
- -DRPI_INCLUDE_DIR=$( $(tc-getPKG_CONFIG) --variable=includedir bcm_host) \
- -DRPI_LIB_DIR=$( $(tc-getPKG_CONFIG) --variable=libdir bcm_host)
- )
-
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- elog "You will need to ensure the user running your CEC client has"
- elog "read/write access to the device. You can ensure this by adding"
- elog "them to the uucp group"
-}