summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 21:44:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-12 21:47:24 +0200
commitac65dfd7c3198cc954b571216dea310361429813 (patch)
tree4f0a69f65b3f28ae57a8a7aa6087b7ed1b7c879d /dev-libs/libcharon/libcharon-3.6.0-r1.ebuild
parentdev-libs/hyperscan: Add missing PYTHON_REQUIRED_USE (diff)
downloadgentoo-ac65dfd7c3198cc954b571216dea310361429813.tar.gz
gentoo-ac65dfd7c3198cc954b571216dea310361429813.tar.bz2
gentoo-ac65dfd7c3198cc954b571216dea310361429813.zip
dev-libs/libcharon: Add missing PYTHON_*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libcharon/libcharon-3.6.0-r1.ebuild')
-rw-r--r--dev-libs/libcharon/libcharon-3.6.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libcharon/libcharon-3.6.0-r1.ebuild b/dev-libs/libcharon/libcharon-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..1edcc8fe92b5
--- /dev/null
+++ b/dev-libs/libcharon/libcharon-3.6.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit cmake-utils python-single-r1
+
+MY_PN="libCharon"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libCharon"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND=${PYTHON_DEPS}
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/${MY_PN}-${PV}"