summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-06 18:19:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-06 22:11:18 +0200
commit6fe423537c02a7851b58420a2f8840bb6991482d (patch)
tree45698a8a7e050bf04b01ba87ac2c589819338088 /dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild
parentsys-devel/clang-runtime: Bump to 16.0.0_pre20221006 (diff)
downloadgentoo-6fe423537c02a7851b58420a2f8840bb6991482d.tar.gz
gentoo-6fe423537c02a7851b58420a2f8840bb6991482d.tar.bz2
gentoo-6fe423537c02a7851b58420a2f8840bb6991482d.zip
dev-libs/libclc: Bump to 16.0.0_pre20221006
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild')
-rw-r--r--dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild b/dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild
new file mode 100644
index 000000000000..2ec99d83a103
--- /dev/null
+++ b/dev-libs/libclc/libclc-16.0.0_pre20221006.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake llvm llvm.org python-any-r1
+
+DESCRIPTION="OpenCL C library"
+HOMEPAGE="https://libclc.llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions || ( MIT BSD )"
+SLOT="0"
+KEYWORDS=""
+IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_r600 video_cards_radeonsi"
+IUSE="${IUSE_VIDEO_CARDS}"
+REQUIRED_USE="|| ( ${IUSE_VIDEO_CARDS} )"
+
+LLVM_MAX_SLOT=16
+BDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ sys-devel/clang:16
+ sys-devel/clang:15
+ sys-devel/clang:14
+ sys-devel/clang:13
+ )
+"
+
+LLVM_COMPONENTS=( libclc )
+llvm.org_set_globals
+
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}"
+}
+
+pkg_setup() {
+ # we do not need llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local libclc_targets=()
+
+ use video_cards_nvidia && libclc_targets+=(
+ "nvptx--"
+ "nvptx64--"
+ "nvptx--nvidiacl"
+ "nvptx64--nvidiacl"
+ )
+ use video_cards_r600 && libclc_targets+=(
+ "r600--"
+ )
+ use video_cards_radeonsi && libclc_targets+=(
+ "amdgcn--"
+ "amdgcn-mesa-mesa3d"
+ "amdgcn--amdhsa"
+ )
+ # TODO: spirv
+ [[ ${#libclc_targets[@]} ]] || die "libclc target missing!"
+
+ libclc_targets=${libclc_targets[*]}
+ local mycmakeargs=(
+ -DLIBCLC_TARGETS_TO_BUILD="${libclc_targets// /;}"
+ -DLLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
+ )
+ cmake_src_configure
+}