summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2018-05-31 20:42:04 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-13 12:25:50 +0200
commitc14f8f2b88923379f73fa7c55702a9d7d89b2887 (patch)
treeb1fd183e251279e81c0d926bd27347e22fe4997b /dev-libs/libdbh/libdbh-5.0.22.ebuild
parentdev-perl/Module-Build-Tiny: restore s390 keyword (diff)
downloadgentoo-c14f8f2b88923379f73fa7c55702a9d7d89b2887.tar.gz
gentoo-c14f8f2b88923379f73fa7c55702a9d7d89b2887.tar.bz2
gentoo-c14f8f2b88923379f73fa7c55702a9d7d89b2887.zip
dev-libs/libdbh: 5.0.22 version bump
Closes: https://bugs.gentoo.org/656990
Diffstat (limited to 'dev-libs/libdbh/libdbh-5.0.22.ebuild')
-rw-r--r--dev-libs/libdbh/libdbh-5.0.22.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libdbh/libdbh-5.0.22.ebuild b/dev-libs/libdbh/libdbh-5.0.22.ebuild
new file mode 100644
index 000000000000..a32cdfb61dfe
--- /dev/null
+++ b/dev-libs/libdbh/libdbh-5.0.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="A small library to create and manage 64-bit disk based hash tables"
+HOMEPAGE="https://www.gnu.org/software/libdbh/"
+SRC_URI="mirror://sourceforge/dbh/dbh/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/gtk-doc-am
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Make sure user defined CFLAGS are respected
+ sed -i -e 's:-O2:${CFLAGS}:' m4/rfm-conditionals.m4 || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}