summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-06-22 15:15:58 -0600
committerTim Harder <radhermit@gentoo.org>2019-06-22 16:40:13 -0600
commitb396a2901ae589eccb3c2fe7ce9cbefb9785758c (patch)
treeb619f2d4575ac22d5d93a626e7d7a289f87cbba0 /dev-libs/libebml/libebml-1.3.9.ebuild
parentpackage.mask: Mask sys-apps/cobalt-panel-utils for removal (diff)
downloadgentoo-b396a2901ae589eccb3c2fe7ce9cbefb9785758c.tar.gz
gentoo-b396a2901ae589eccb3c2fe7ce9cbefb9785758c.tar.bz2
gentoo-b396a2901ae589eccb3c2fe7ce9cbefb9785758c.zip
dev-libs/libebml: version bump to 1.3.9
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-libs/libebml/libebml-1.3.9.ebuild')
-rw-r--r--dev-libs/libebml/libebml-1.3.9.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/libebml/libebml-1.3.9.ebuild b/dev-libs/libebml/libebml-1.3.9.ebuild
new file mode 100644
index 000000000000..daa59d42571e
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.3.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="https://www.matroska.org/ https://github.com/Matroska-Org/libebml/"
+SRC_URI="https://dl.matroska.org/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=YES )
+ cmake-utils_src_configure
+}