summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libev/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libev/files')
-rw-r--r--dev-libs/libev/files/libev-4.15-automake-1.14.patch21
-rw-r--r--dev-libs/libev/files/libev-pc.patch42
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libev/files/libev-4.15-automake-1.14.patch b/dev-libs/libev/files/libev-4.15-automake-1.14.patch
new file mode 100644
index 000000000000..22fcc1a0093f
--- /dev/null
+++ b/dev-libs/libev/files/libev-4.15-automake-1.14.patch
@@ -0,0 +1,21 @@
+Gentoo bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=493050
+Patch-by: Dennis 'dlan' Lan <dennis.yxun@gmail.com>
+
+diff --git a/configure.ac b/configure.ac
+index 7ea3ec8..290fce0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,11 +1,12 @@
+ AC_INIT
+
++AM_INIT_AUTOMAKE(libev,4.15) dnl also update ev.h!
++
+ orig_CFLAGS="$CFLAGS"
+
+ AC_CONFIG_SRCDIR([ev_epoll.c])
+ AC_CONFIG_MACRO_DIR([m4])
+
+-AM_INIT_AUTOMAKE(libev,4.15) dnl also update ev.h!
+ AC_CONFIG_HEADERS([config.h])
+ AM_MAINTAINER_MODE
+
diff --git a/dev-libs/libev/files/libev-pc.patch b/dev-libs/libev/files/libev-pc.patch
new file mode 100644
index 000000000000..a2a4c62a1ac8
--- /dev/null
+++ b/dev-libs/libev/files/libev-pc.patch
@@ -0,0 +1,42 @@
+--- /dev/null
++++ b/libev.pc.in
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: libev
++Description: A high-performance event loop/event model with lots of features
++Version: @VERSION@
++Libs: -L${libdir} -lev
++Libs.private:
++Cflags: -I${includedir}
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -16,5 +16,8 @@ lib_LTLIBRARIES = libev.la
+ libev_la_SOURCES = ev.c event.c
+ libev_la_LDFLAGS = -version-info $(VERSION_INFO)
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libev.pc
++
+ ev.3: ev.pod
+ pod2man -n LIBEV -r "libev-$(VERSION)" -c "libev - high performance full featured event loop" -s3 <$< >$@
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,6 +2,7 @@ orig_CFLAGS="$CFLAGS"
+
+ AC_INIT
+ AC_CONFIG_SRCDIR([ev_epoll.c])
++AC_CONFIG_MACRO_DIR([m4])
+
+ AM_INIT_AUTOMAKE(libev,4.11) dnl also update ev.h!
+ AC_CONFIG_HEADERS([config.h])
+@@ -21,5 +22,5 @@ AC_PROG_LIBTOOL
+
+ m4_include([libev.m4])
+
+-AC_CONFIG_FILES([Makefile])
++AC_CONFIG_FILES([Makefile libev.pc])
+ AC_OUTPUT