summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-16 23:23:05 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-16 23:27:05 -0500
commit26a6497501582b1de76287a896cf39faa7364e1d (patch)
tree0e32065162fae2e8c528e32c6ef1f495af3df3f1 /dev-libs/libevdev/libevdev-1.10.0.ebuild
parentmedia-sound/sc2mpd: patch out -Werror (diff)
downloadgentoo-26a6497501582b1de76287a896cf39faa7364e1d.tar.gz
gentoo-26a6497501582b1de76287a896cf39faa7364e1d.tar.bz2
gentoo-26a6497501582b1de76287a896cf39faa7364e1d.zip
dev-libs/libevdev: Version bump to 1.10.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libevdev/libevdev-1.10.0.ebuild')
-rw-r--r--dev-libs/libevdev/libevdev-1.10.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/libevdev/libevdev-1.10.0.ebuild b/dev-libs/libevdev/libevdev-1.10.0.ebuild
new file mode 100644
index 000000000000..b1bba3f2823e
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.10.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit meson multilib-minimal python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson test -v -C "${BUILD_DIR}" -t 100 || die "tests failed"
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}