summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-21 15:13:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-21 15:58:29 +0200
commite45c5ea789eeda86a42427ad74ab65cbc894cae7 (patch)
treeefb35c2fd7d01b7e91cf2f804255354032dadc8e /dev-libs/libevent/libevent-9999.ebuild
parentdev-libs/libevent: Add unkeyworded 2.2.1 for testing (diff)
downloadgentoo-e45c5ea789eeda86a42427ad74ab65cbc894cae7.tar.gz
gentoo-e45c5ea789eeda86a42427ad74ab65cbc894cae7.tar.bz2
gentoo-e45c5ea789eeda86a42427ad74ab65cbc894cae7.zip
dev-libs/libevent: Sync the live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/libevent/libevent-9999.ebuild')
-rw-r--r--dev-libs/libevent/libevent-9999.ebuild45
1 files changed, 22 insertions, 23 deletions
diff --git a/dev-libs/libevent/libevent-9999.ebuild b/dev-libs/libevent/libevent-9999.ebuild
index f5619ac0a1b0..a0edf66184dc 100644
--- a/dev-libs/libevent/libevent-9999.ebuild
+++ b/dev-libs/libevent/libevent-9999.ebuild
@@ -1,42 +1,39 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools git-r3 multilib-minimal
DESCRIPTION="Library to execute a function when a specific event occurs on a file descriptor"
-EGIT_REPO_URI="https://github.com/libevent/libevent"
HOMEPAGE="
https://libevent.org/
- https://github.com/libevent/libevent
+ https://github.com/libevent/libevent/
"
+EGIT_REPO_URI="https://github.com/libevent/libevent.git"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/2.2"
KEYWORDS=""
IUSE="
- +clock-gettime debug malloc-replacement mbedtls +ssl static-libs
+ +clock-gettime debug malloc-replacement mbedtls +openssl static-libs
test verbose-debug
"
+# TODO: hangs
RESTRICT="test"
DEPEND="
- mbedtls? ( net-libs/mbedtls )
- ssl? (
- >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
- )
+ mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
+ openssl? ( >=dev-libs/openssl-1.0.1h-r2:=[${MULTILIB_USEDEP}] )
"
RDEPEND="
${DEPEND}
- !<=dev-libs/9libs-1.0
"
+DOCS=( README.md ChangeLog{,-1.4,-2.0} whatsnew-2.{0,1}.txt )
MULTILIB_WRAPPED_HEADERS=(
/usr/include/event2/event-config.h
)
-DOCS=(
- ChangeLog{,-1.4,-2.0}
-)
src_prepare() {
default
@@ -47,17 +44,19 @@ multilib_src_configure() {
# fix out-of-source builds
mkdir -p test || die
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable clock-gettime) \
- $(use_enable debug debug-mode) \
- $(use_enable malloc-replacement malloc-replacement) \
- $(use_enable mbedtls) \
- $(use_enable ssl openssl) \
- $(use_enable static-libs static) \
- $(use_enable test libevent-regress) \
- $(use_enable verbose-debug) \
+ local ECONF_SOURCE="${S}"
+ local myconf=(
+ $(use_enable clock-gettime)
+ $(use_enable debug debug-mode)
+ $(use_enable malloc-replacement malloc-replacement)
+ $(use_enable mbedtls)
+ $(use_enable openssl)
+ $(use_enable static-libs static)
+ $(use_enable test libevent-regress)
+ $(use_enable verbose-debug)
--disable-samples
+ )
+ econf "${myconf[@]}"
}
multilib_src_install_all() {