summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-01-27 14:49:55 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-01-27 16:10:45 +0100
commitc7d9adee69adef759c350e6f017ac4ef9951c954 (patch)
tree12023ecce5dc36592ebed54e90a2a31db6e0c1db /dev-libs/libfastjson
parentdev-libs/librdkafka: bump to v1.6.0 (diff)
downloadgentoo-c7d9adee69adef759c350e6f017ac4ef9951c954.tar.gz
gentoo-c7d9adee69adef759c350e6f017ac4ef9951c954.tar.bz2
gentoo-c7d9adee69adef759c350e6f017ac4ef9951c954.zip
dev-libs/libfastjson: bump to v0.99.9
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/libfastjson')
-rw-r--r--dev-libs/libfastjson/Manifest1
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/Manifest b/dev-libs/libfastjson/Manifest
index 3b7b2dfd27e7..d05dabe0f415 100644
--- a/dev-libs/libfastjson/Manifest
+++ b/dev-libs/libfastjson/Manifest
@@ -1 +1,2 @@
DIST libfastjson-0.99.8.tar.gz 433819 BLAKE2B f988c01de8e7becc5a848825c18151fec2b80f81eb5b50e459b1a3bb535f5521fb63e9350eb133eb984f57f42c5f529220a0c9461eb4689e1421ad815c4c4d87 SHA512 1e7eb7eaae2c6ccb78b77ac883808e1d311b03bad083dc72ab7712765a2ed139accd762850d60f54c6fe0ad48c4385714818fd2c8ed76700ce3546e5aff1c823
+DIST libfastjson-0.99.9.tar.gz 436502 BLAKE2B 5ed542f373dee2e28c85f8b48e9d35c7727d7e565c691f90caed7a9ac1192814c6371e03bce18dd9765b4251e6a78b7e612eeb38872d2833cd72021d41fb889a SHA512 90505fba033179aa92f12ac5dbbb071f69f3491de5bbbbb46d553b08ac325448459c9e33ba22ef4f9db0bae4496cca60046eebf6325d70b045c1a0a9845b0d48
diff --git a/dev-libs/libfastjson/libfastjson-0.99.9.ebuild b/dev-libs/libfastjson/libfastjson-0.99.9.ebuild
new file mode 100644
index 000000000000..3c3e3ed274cb
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="https://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-devel/autoconf-archive-2015.02.04"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ $(use_enable static-libs static)
+ --disable-rdrand
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}