summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-17 15:12:40 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-17 15:16:50 -0700
commitab5af86bb9051eb3c72c51c5b2fceb45625d95aa (patch)
treec026b568aae00530df4923546b9700fe82d57aeb /dev-libs/libfido2/files
parentsys-fs/btrfs-progs: Python 3.8 compatibility (diff)
downloadgentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.tar.gz
gentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.tar.bz2
gentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.zip
dev-libs/libfido2-1.4.0: Version bump, remove Werror (bug #717952)
Bug: https://bugs.gentoo.org/717952 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/libfido2/files')
-rw-r--r--dev-libs/libfido2/files/libfido2-1.4.0-cmakelists.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libfido2/files/libfido2-1.4.0-cmakelists.patch b/dev-libs/libfido2/files/libfido2-1.4.0-cmakelists.patch
new file mode 100644
index 000000000000..df34a85dacc2
--- /dev/null
+++ b/dev-libs/libfido2/files/libfido2-1.4.0-cmakelists.patch
@@ -0,0 +1,34 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0bb2e87..4d0ed00 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -128,13 +128,11 @@ else()
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wshadow")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wwrite-strings")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wmissing-prototypes")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wbad-function-cast")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pedantic-errors")
+ check_c_compiler_flag("-fstack-protector-all" HAVE_STACK_PROTECTOR_ALL)
+ if(HAVE_STACK_PROTECTOR_ALL)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-protector-all")
+diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
+index 44e4a96..d04dacc 100644
+--- a/man/CMakeLists.txt
++++ b/man/CMakeLists.txt
+@@ -5,11 +5,6 @@
+ find_program(MANDOC_PATH mandoc)
+ message(STATUS "MANDOC_PATH: ${MANDOC_PATH}")
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD" OR CMAKE_SYSTEM_NAME STREQUAL "Linux")
+- find_program(GZIP_PATH gzip)
+- message(STATUS "GZIP_PATH: ${GZIP_PATH}")
+-endif()
+-
+ list(APPEND MAN_SOURCES
+ eddsa_pk_new.3
+ es256_pk_new.3