summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-17 15:12:40 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-17 15:16:50 -0700
commitab5af86bb9051eb3c72c51c5b2fceb45625d95aa (patch)
treec026b568aae00530df4923546b9700fe82d57aeb /dev-libs/libfido2/libfido2-1.4.0.ebuild
parentsys-fs/btrfs-progs: Python 3.8 compatibility (diff)
downloadgentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.tar.gz
gentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.tar.bz2
gentoo-ab5af86bb9051eb3c72c51c5b2fceb45625d95aa.zip
dev-libs/libfido2-1.4.0: Version bump, remove Werror (bug #717952)
Bug: https://bugs.gentoo.org/717952 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/libfido2/libfido2-1.4.0.ebuild')
-rw-r--r--dev-libs/libfido2/libfido2-1.4.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libfido2/libfido2-1.4.0.ebuild b/dev-libs/libfido2/libfido2-1.4.0.ebuild
new file mode 100644
index 000000000000..41493d5b2f7a
--- /dev/null
+++ b/dev-libs/libfido2/libfido2-1.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils udev linux-info
+
+DESCRIPTION="Provides library functionality for FIDO 2.0"
+HOMEPAGE="https://github.com/Yubico/libfido2"
+SRC_URI="https://github.com/Yubico/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="libressl +static-libs"
+
+DEPEND="
+ dev-libs/libcbor:=
+ virtual/libudev:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/libfido2-1.4.0-cmakelists.patch"
+)
+
+pkg_pretend() {
+ CONFIG_CHECK="
+ ~USB_HID
+ ~HIDRAW
+ "
+
+ check_extra_config
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use static-libs; then
+ rm -f "${D}/$(get_libdir)"/*.a || die
+ fi
+
+ udev_newrules udev/70-u2f.rules 70-libfido2-u2f.rules
+}