summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:34:22 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-05-29 14:34:22 +0200
commit28bc479cae64f871145e0c4fbe323481b353d0eb (patch)
tree9f0e0de04c809cb3de7feb16a467fb1555b67171 /dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild
parentx11-plugins/wmdrawer: decompress manpage, bug #619980 (diff)
downloadgentoo-28bc479cae64f871145e0c4fbe323481b353d0eb.tar.gz
gentoo-28bc479cae64f871145e0c4fbe323481b353d0eb.tar.bz2
gentoo-28bc479cae64f871145e0c4fbe323481b353d0eb.zip
dev-libs/libfilezilla: 0.9.2 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild')
-rw-r--r--dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild b/dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild
new file mode 100644
index 000000000000..f55baf0c24b7
--- /dev/null
+++ b/dev-libs/libfilezilla/libfilezilla-0.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="C++ library offering some basic functionality for platform-independent programs"
+HOMEPAGE="https://lib.filezilla-project.org/"
+SRC_URI="mirror://sourceforge/filezilla/${P}.tar.bz2
+ http://download.filezilla-project.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}