summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-30 06:36:52 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-30 07:08:25 +0200
commite7773552b82db1a5b7a10fbf9f5c86d77a0b2e8b (patch)
treecc95584a8bd84cf884e37bd22b7da190c574b321 /dev-libs/libflatarray/libflatarray-0.2.0.ebuild
parentapp-text/calibre: Bump to version 3.47.0 (diff)
downloadgentoo-e7773552b82db1a5b7a10fbf9f5c86d77a0b2e8b.tar.gz
gentoo-e7773552b82db1a5b7a10fbf9f5c86d77a0b2e8b.tar.bz2
gentoo-e7773552b82db1a5b7a10fbf9f5c86d77a0b2e8b.zip
dev-libs/libflatarray: added version 0.2.0
This version is required to build libgeodecomp, latest one seems not to be supported yet. Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'dev-libs/libflatarray/libflatarray-0.2.0.ebuild')
-rw-r--r--dev-libs/libflatarray/libflatarray-0.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libflatarray/libflatarray-0.2.0.ebuild b/dev-libs/libflatarray/libflatarray-0.2.0.ebuild
new file mode 100644
index 000000000000..35250d070a6f
--- /dev/null
+++ b/dev-libs/libflatarray/libflatarray-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils cuda
+
+SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="Struct of arrays library with object oriented interface for C++"
+HOMEPAGE="http://www.libgeodecomp.org/libflatarray.html"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="cuda doc"
+
+DEPEND="
+ doc? ( app-doc/doxygen )
+ cuda? ( dev-util/nvidia-cuda-toolkit )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_CUDA=$(usex cuda)
+ -DWITH_SILO=false
+ )
+ cmake-utils_src_configure
+}