summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-01-04 09:51:24 -0500
committerCraig Andrews <candrews@gentoo.org>2024-01-04 09:51:38 -0500
commitdd0409bf8da2017f2c7cb7310335b8a07d45975f (patch)
tree297d4bcebd96cd16d137f3752365a9220eae917f /dev-libs/libfmt/libfmt-10.2.1.ebuild
parentapp-emulation/wine-proton: update live (diff)
downloadgentoo-dd0409bf8da2017f2c7cb7310335b8a07d45975f.tar.gz
gentoo-dd0409bf8da2017f2c7cb7310335b8a07d45975f.tar.bz2
gentoo-dd0409bf8da2017f2c7cb7310335b8a07d45975f.zip
dev-libs/libfmt: add 10.2.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt/libfmt-10.2.1.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-10.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-10.2.1.ebuild b/dev-libs/libfmt/libfmt-10.2.1.ebuild
new file mode 100644
index 000000000000..0914ef073c62
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-10.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}