summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-11-02 20:38:39 -0500
committerCraig Andrews <candrews@gentoo.org>2020-11-02 20:39:42 -0500
commitd69b66a7d62aab75430dccd33f577742013ff8ae (patch)
treedb55c52978b573b01aa25a1d429ac79bbb75a8ef /dev-libs/libfmt/libfmt-7.1.1.ebuild
parentsys-cluster/ceph-14.2.13: Version bump (diff)
downloadgentoo-d69b66a7d62aab75430dccd33f577742013ff8ae.tar.gz
gentoo-d69b66a7d62aab75430dccd33f577742013ff8ae.tar.bz2
gentoo-d69b66a7d62aab75430dccd33f577742013ff8ae.zip
dev-libs/libfmt: 7.1.1 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt/libfmt-7.1.1.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-7.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-7.1.1.ebuild b/dev-libs/libfmt/libfmt-7.1.1.ebuild
new file mode 100644
index 000000000000..376757b05ade
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-7.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}