summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-06-22 10:41:54 -0400
committerCraig Andrews <candrews@gentoo.org>2021-06-22 10:44:25 -0400
commite88caaf664d63a663bc1843fc5742ca1c2c4215a (patch)
tree9c06fbed4c636d94e8d563f87f2214147c743a5a /dev-libs/libfmt/libfmt-8.0.0-r1.ebuild
parentsys-apps/man-pages: Bump to version 5.12 (diff)
downloadgentoo-e88caaf664d63a663bc1843fc5742ca1c2c4215a.tar.gz
gentoo-e88caaf664d63a663bc1843fc5742ca1c2c4215a.tar.bz2
gentoo-e88caaf664d63a663bc1843fc5742ca1c2c4215a.zip
dev-libs/libfmt: do not use UDL types when UDL not used
Closes: https://bugs.gentoo.org/797406 See: https://github.com/fmtlib/fmt/pull/2376 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt/libfmt-8.0.0-r1.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-8.0.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-8.0.0-r1.ebuild b/dev-libs/libfmt/libfmt-8.0.0-r1.ebuild
new file mode 100644
index 000000000000..d489205c5abf
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-8.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-udl-define.patch"
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}