summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-01-14 14:32:49 +0800
committerSam James <sam@gentoo.org>2023-01-14 19:14:38 +0000
commit5957215571383490d2799238d2ce7e50349b1371 (patch)
treef50781f09df1bd4c43ec41ae6ff7aaaa2564aee0 /dev-libs/libgcrypt
parentnet-libs/libtirpc: fix build with lld-16 (diff)
downloadgentoo-5957215571383490d2799238d2ce7e50349b1371.tar.gz
gentoo-5957215571383490d2799238d2ce7e50349b1371.tar.bz2
gentoo-5957215571383490d2799238d2ce7e50349b1371.zip
dev-libs/libgcrypt: fix build with lld-16
Signed-off-by: WANG Xuerui <xen0n@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.1-r2.ebuild9
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild9
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild9
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.1-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.1-r2.ebuild
index 5614f817ecb3..fdaaf606e1e9 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.1-r2.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -105,6 +105,13 @@ multilib_src_configure() {
append-flags -fno-tree-loop-vectorize
fi
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
diff --git a/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
index aaa53b979288..38cdf50ad91f 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.10.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -106,6 +106,13 @@ multilib_src_configure() {
append-flags -fno-tree-loop-vectorize
fi
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"
diff --git a/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
index c7a2a6fe71fc..d164dfc4b237 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -78,6 +78,13 @@ multilib_src_configure() {
append-flags -fno-tree-loop-vectorize
fi
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"