summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-11 12:19:33 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-11 12:56:02 -0800
commitc35a91d8a4d4eabdf990fafcb01a5a56a5551b9c (patch)
tree7feb6fafc700572409b969a3d63bbe2132236629 /dev-libs/libgee
parentdev-cpp/mm-common: Version bump to 1.0.4 (diff)
downloadgentoo-c35a91d8a4d4eabdf990fafcb01a5a56a5551b9c.tar.gz
gentoo-c35a91d8a4d4eabdf990fafcb01a5a56a5551b9c.tar.bz2
gentoo-c35a91d8a4d4eabdf990fafcb01a5a56a5551b9c.zip
dev-libs/libgee: Version bump to 0.20.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgee')
-rw-r--r--dev-libs/libgee/Manifest1
-rw-r--r--dev-libs/libgee/libgee-0.20.5.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libgee/Manifest b/dev-libs/libgee/Manifest
index 5393ade8e324..690ac85bf5a8 100644
--- a/dev-libs/libgee/Manifest
+++ b/dev-libs/libgee/Manifest
@@ -1 +1,2 @@
DIST libgee-0.20.4.tar.xz 684068 BLAKE2B b40d37f5d90abb8d96d5e90c67056573960bd54cadfb1cb5daf7fc07147a9e1706e23bf0240b84245c7e1ffb814c5e358f12e974a0d8a038b0179be25f271d90 SHA512 9a4b1db47543e80a6191054fa8fb04a8c07468befe05f738409ede317e64a8b884157bb488b330cd27f3dce3af5eeb7aefb74a180c2913ed8c834d1bde8fe9c5
+DIST libgee-0.20.5.tar.xz 687440 BLAKE2B 0f9c1d42c28a080ed66a4ad4ab7e84bf4489e936a5b800a435dfd5a0d812d2ca9a47eacab28fca8862c4dfa57dab6595ddf7a0ff6955150b58c12fef77c5a26a SHA512 64d498c5323c4c0978391a01fb3a36e9a00ef9d5dc8e95e3b2dc9cc33f6ad55ec1096e18629c5cad9539b083c42917d91d068824dac4d06f53ef9a682cccc8a9
diff --git a/dev-libs/libgee/libgee-0.20.5.ebuild b/dev-libs/libgee/libgee-0.20.5.ebuild
new file mode 100644
index 000000000000..9caa9dce4de9
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.20.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ VALAC="$(type -P false)"
+}