summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-12 17:26:40 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-12 18:07:53 +0100
commitb0b200c760f3de118621be62ecf7b673fca2c583 (patch)
treefc4afbac38a2adb15c9a891ba6ee0f6712b1d41b /dev-libs/libgit2/libgit2-9999.ebuild
parentmate-base/mate-session-manager: Revbump (diff)
downloadgentoo-b0b200c760f3de118621be62ecf7b673fca2c583.tar.gz
gentoo-b0b200c760f3de118621be62ecf7b673fca2c583.tar.bz2
gentoo-b0b200c760f3de118621be62ecf7b673fca2c583.zip
dev-libs/libgit2: Bump to EAPI=6, modernize
Diffstat (limited to 'dev-libs/libgit2/libgit2-9999.ebuild')
-rw-r--r--dev-libs/libgit2/libgit2-9999.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/dev-libs/libgit2/libgit2-9999.ebuild b/dev-libs/libgit2/libgit2-9999.ebuild
index 899540f73af0..19fc4bd0b35b 100644
--- a/dev-libs/libgit2/libgit2-9999.ebuild
+++ b/dev-libs/libgit2/libgit2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit cmake-utils multilib
+inherit cmake-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
@@ -21,8 +21,8 @@ SLOT="0/26"
IUSE="examples gssapi libressl +ssh test +threads trace"
RDEPEND="
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
sys-libs/zlib
net-libs/http-parser:=
gssapi? ( virtual/krb5 )
@@ -44,11 +44,11 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
- $(cmake-utils_use_build test CLAR)
- $(cmake-utils_use_enable trace TRACE)
- $(cmake-utils_use_use gssapi GSSAPI)
- $(cmake-utils_use_use ssh SSH)
- $(cmake-utils_use threads THREADSAFE)
+ -DBUILD_CLAR=$(usex test)
+ -DENABLE_TRACE=$(usex trace)
+ -DUSE_GSSAPI=$(usex gssapi)
+ -DUSE_SSH=$(usex ssh)
+ -DTHREADSAFE=$(usex threads)
)
cmake-utils_src_configure
}
@@ -68,7 +68,7 @@ src_install() {
cmake-utils_src_install
if use examples ; then
- egit_clean examples
+ find examples -name '.gitignore' -delete || die
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi