summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-21 16:22:00 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-21 17:59:42 -0400
commitf1fa6c0b542ea8b14792514b728e7b559021d8ab (patch)
tree56718ae1b0dd978eaa27389b7c50a7d17767d1ba /dev-libs/libgnome-games-support
parentgnome.org.eclass: Update GNOME_ORG_PVP logic for v40 releases (diff)
downloadgentoo-f1fa6c0b542ea8b14792514b728e7b559021d8ab.tar.gz
gentoo-f1fa6c0b542ea8b14792514b728e7b559021d8ab.tar.bz2
gentoo-f1fa6c0b542ea8b14792514b728e7b559021d8ab.zip
dev-libs/libgnome-games-support: Version bump to 1.8.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgnome-games-support')
-rw-r--r--dev-libs/libgnome-games-support/Manifest1
-rw-r--r--dev-libs/libgnome-games-support/libgnome-games-support-1.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libgnome-games-support/Manifest b/dev-libs/libgnome-games-support/Manifest
index 85ed82a75dd5..116c9fb0e88a 100644
--- a/dev-libs/libgnome-games-support/Manifest
+++ b/dev-libs/libgnome-games-support/Manifest
@@ -1 +1,2 @@
DIST libgnome-games-support-1.6.1.tar.xz 44012 BLAKE2B a7ef470f955d400a07d62452a7e2b0846e9ea6d01729bc6175963c474ea8a278a4903fd8bb1e0cdf9a19006f7306cb457901d20757573ba4fc35cf8d0397aa1c SHA512 a2f0c6faea4e10fcc06487a37147a3bbee9d41daeff2a323cf078bef45664166184f63e11fdba4afe6d2d1f8f2c0dba59274707d978c84b17b70305cb206b3a8
+DIST libgnome-games-support-1.8.0.tar.xz 44808 BLAKE2B e6195087e99a3d34f47af6b4e0d9f068aa7b0a80d545da11744173ff8c881c62f81c913f8d59f855a71f4754ca92d09afdf79e1571cb3adfcf90d60b589d73c9 SHA512 0de9523d590dcc00b628bf88115161da94d5f3e7b3e074f4db851b6cb711d65601c290ec6e0485aaf4e4759faf82e7b1c10a2a26656d44874adaa7e8358f7124
diff --git a/dev-libs/libgnome-games-support/libgnome-games-support-1.8.0.ebuild b/dev-libs/libgnome-games-support/libgnome-games-support-1.8.0.ebuild
new file mode 100644
index 000000000000..38664f56d3d4
--- /dev/null
+++ b/dev-libs/libgnome-games-support/libgnome-games-support-1.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library for code common to GNOME games"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgnome-games-support"
+
+LICENSE="LGPL-3+"
+SLOT="1/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+# glib dep in meson is 2.40, but vala is passed 2.44 target
+RDEPEND="
+ >=dev-libs/libgee-0.14.0:0.8=
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.19.2:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}