summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-06-11 20:58:18 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-06-11 21:21:28 +0200
commitcaf07e799877ea3e933b35b7402bc916c246132d (patch)
tree69f0c5f194c2fed001a04a75cb26fa4852eec415 /dev-libs/libgnt
parentmedia-video/vdr2jpeg: cannot run 'strip' fixed (diff)
downloadgentoo-caf07e799877ea3e933b35b7402bc916c246132d.tar.gz
gentoo-caf07e799877ea3e933b35b7402bc916c246132d.tar.bz2
gentoo-caf07e799877ea3e933b35b7402bc916c246132d.zip
dev-libs/libgnt: Initial commit
Use same KEYWORDS like in pidgin as this is an outsourced pidgin plugin Bug: https://bugs.gentoo.org/727878 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libgnt')
-rw-r--r--dev-libs/libgnt/Manifest1
-rw-r--r--dev-libs/libgnt/files/libgnt-2.14.0-optional_docs.patch15
-rw-r--r--dev-libs/libgnt/files/libgnt-2.14.0-tinfo.patch18
-rw-r--r--dev-libs/libgnt/libgnt-2.14.0.ebuild37
-rw-r--r--dev-libs/libgnt/metadata.xml8
5 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/libgnt/Manifest b/dev-libs/libgnt/Manifest
new file mode 100644
index 000000000000..088bdd50ab90
--- /dev/null
+++ b/dev-libs/libgnt/Manifest
@@ -0,0 +1 @@
+DIST libgnt-2.14.0.tar.xz 102444 BLAKE2B 303dc33e60571ba4b5b9cc8ce477807b9b2ed6b4d1ed14e40c43e146a6d3d156741597befdf3e6c0c6816e9d43955f57f9e1b61e3f1f2d2fc451bf53f7236022 SHA512 0d9c5550374696a0e6ede5246cda3c372d7055d21b9ffaf10be88d6a469bdf18c7dd1113ec612acf4889c0e5686ea87bb0e8348ca8985fd5ff8913afc5813b38
diff --git a/dev-libs/libgnt/files/libgnt-2.14.0-optional_docs.patch b/dev-libs/libgnt/files/libgnt-2.14.0-optional_docs.patch
new file mode 100644
index 000000000000..aded0c047674
--- /dev/null
+++ b/dev-libs/libgnt/files/libgnt-2.14.0-optional_docs.patch
@@ -0,0 +1,15 @@
+--- libgnt-2.14.0/meson.build
++++ libgnt-2.14.0/meson.build
+@@ -231,4 +231,6 @@
+
+ subdir('wms')
+ subdir('test')
+-subdir('doc')
++if get_option('doc')
++ subdir('doc')
++endif
+--- libgnt-2.14.0/meson_options.txt
++++ libgnt-2.14.0/meson_options.txt
+@@ -0,0 +1,2 @@
++option('doc', type : 'boolean', value : true,
++ description : 'build documentation with gtk-doc')
diff --git a/dev-libs/libgnt/files/libgnt-2.14.0-tinfo.patch b/dev-libs/libgnt/files/libgnt-2.14.0-tinfo.patch
new file mode 100644
index 000000000000..1e4ab49020b9
--- /dev/null
+++ b/dev-libs/libgnt/files/libgnt-2.14.0-tinfo.patch
@@ -0,0 +1,18 @@
+--- libgnt-2.14.0/meson.build
++++ libgnt-2.14.0/meson.build
+@@ -72,6 +72,7 @@
+ ncurses_available = true
+ ncurses_inc = []
+ ncurses_libs = [
++ compiler.find_library('tinfow', required : false),
+ compiler.find_library('ncursesw', required : false),
+ compiler.find_library('panelw', required : false)
+ ]
+@@ -113,6 +114,7 @@
+ else
+ # ncursesw was not found. Look for plain old ncurses
+ ncurses_libs = [
++ compiler.find_library('tinfo', required : false),
+ compiler.find_library('ncurses', required : false),
+ compiler.find_library('panel', required : false)
+ ]
diff --git a/dev-libs/libgnt/libgnt-2.14.0.ebuild b/dev-libs/libgnt/libgnt-2.14.0.ebuild
new file mode 100644
index 000000000000..74cd1cd56701
--- /dev/null
+++ b/dev-libs/libgnt/libgnt-2.14.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Pidgin's GLib Ncurses Toolkit"
+HOMEPAGE="https://bitbucket.org/pidgin/libgnt"
+SRC_URI="mirror://sourceforge/pidgin/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.14.0-optional_docs.patch"
+ "${FILESDIR}/${PN}-2.14.0-tinfo.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/libgnt/metadata.xml b/dev-libs/libgnt/metadata.xml
new file mode 100644
index 000000000000..c7be278b6458
--- /dev/null
+++ b/dev-libs/libgnt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>