summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-04-06 10:59:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-04-06 10:59:25 -0400
commitffea62559c4ccc708bae917eddf777e537d561f0 (patch)
tree7f11ddbd51b4e8e07450b1871721dc6bed0a0a57 /dev-libs/libgpiod/libgpiod-1.0.ebuild
parentsci-mathematics/gimps: amd64 stable (diff)
downloadgentoo-ffea62559c4ccc708bae917eddf777e537d561f0.tar.gz
gentoo-ffea62559c4ccc708bae917eddf777e537d561f0.tar.bz2
gentoo-ffea62559c4ccc708bae917eddf777e537d561f0.zip
dev-libs/libgpiod: initial commit
Diffstat (limited to 'dev-libs/libgpiod/libgpiod-1.0.ebuild')
-rw-r--r--dev-libs/libgpiod/libgpiod-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/libgpiod-1.0.ebuild b/dev-libs/libgpiod/libgpiod-1.0.ebuild
new file mode 100644
index 000000000000..c83a38aa5e72
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://dev.gentoo.org/~blueness/libgpiod/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable tools)
+}
+
+multilib_src_install() {
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+ find "${D}" -name '*.la' -delete || die
+}