summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-12-19 16:24:39 +0200
committerMart Raudsepp <leio@gentoo.org>2020-12-19 17:13:47 +0200
commitc768813ef9d1c830a0c6a0185c8efbca912a338c (patch)
tree6ae3027df77226ec297f738e981f3fcd35eeb8d0 /dev-libs/libgudev/libgudev-234.ebuild
parentapp-text/gspell: remove old (diff)
downloadgentoo-c768813ef9d1c830a0c6a0185c8efbca912a338c.tar.gz
gentoo-c768813ef9d1c830a0c6a0185c8efbca912a338c.tar.bz2
gentoo-c768813ef9d1c830a0c6a0185c8efbca912a338c.zip
dev-libs/libgudev: bump to 234
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libgudev/libgudev-234.ebuild')
-rw-r--r--dev-libs/libgudev/libgudev-234.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libgudev/libgudev-234.ebuild b/dev-libs/libgudev/libgudev-234.ebuild
new file mode 100644
index 000000000000..e163aab6636e
--- /dev/null
+++ b/dev-libs/libgudev/libgudev-234.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GObject bindings for libudev"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgudev"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="introspection static-libs"
+
+DEPEND="
+ >=dev-libs/glib-2.38.0:2[${MULTILIB_USEDEP},static-libs?]
+ >=virtual/libudev-199:=[${MULTILIB_USEDEP},static-libs(-)?]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+RDEPEND="${DEPEND}
+ !sys-fs/eudev[gudev(-)]
+ !sys-fs/udev[gudev(-)]
+ !sys-apps/systemd[gudev(-)]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local myconf=(
+ $(multilib_native_use_enable introspection)
+ $(use_enable static-libs static)
+ --disable-umockdev # umockdev tests currently don't pass (might need extra setup)
+ )
+ local ECONF_SOURCE="${S}"
+ gnome2_src_configure "${myconf[@]}"
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}