summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-30 22:36:29 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-30 22:37:09 +0200
commit891bf3eaf8f1e1a34eb869ecc012e869eae26b29 (patch)
tree6b080c1615a41e52fe60aeda55ddd83b33c25407 /dev-libs/libgweather/files
parentdev-libs/jsonrpc-glib: remove old (diff)
downloadgentoo-891bf3eaf8f1e1a34eb869ecc012e869eae26b29.tar.gz
gentoo-891bf3eaf8f1e1a34eb869ecc012e869eae26b29.tar.bz2
gentoo-891bf3eaf8f1e1a34eb869ecc012e869eae26b29.zip
dev-libs/libgweather: bump to 3.32.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather/files')
-rw-r--r--dev-libs/libgweather/files/3.32.1-meson-tweaks.patch109
1 files changed, 109 insertions, 0 deletions
diff --git a/dev-libs/libgweather/files/3.32.1-meson-tweaks.patch b/dev-libs/libgweather/files/3.32.1-meson-tweaks.patch
new file mode 100644
index 000000000000..9d1bdc017c20
--- /dev/null
+++ b/dev-libs/libgweather/files/3.32.1-meson-tweaks.patch
@@ -0,0 +1,109 @@
+From ad9fa6e469c4eba423b0f7bd5fbd7a76f6165ffe Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 23 Feb 2019 12:21:01 +0200
+Subject: [PATCH] build: Provide introspection option and don't build manual
+ tests
+
+---
+ libgweather/meson.build | 21 ++++++++++++++-------
+ meson.build | 4 ++++
+ meson_options.txt | 2 ++
+ 3 files changed, 20 insertions(+), 7 deletions(-)
+
+diff --git a/libgweather/meson.build b/libgweather/meson.build
+index 6688807..6776839 100644
+--- a/libgweather/meson.build
++++ b/libgweather/meson.build
+@@ -66,6 +66,15 @@ lib_libgweather = shared_library('gweather-3',
+ install: true,
+ )
+
++libgweather_dep = declare_dependency(
++ sources: [gweather_enum_types[1]],
++ dependencies: deps_libgweather,
++ link_with: lib_libgweather,
++ include_directories: root_inc,
++)
++
++if get_option('introspection')
++
+ gweather_gir = gnome.generate_gir(lib_libgweather,
+ sources: introspection_sources,
+ dependencies: deps_libgweather,
+@@ -83,13 +92,6 @@ gweather_gir = gnome.generate_gir(lib_libgweather,
+ install: true,
+ )
+
+-libgweather_dep = declare_dependency(
+- sources: [gweather_enum_types[1], gweather_gir],
+- dependencies: deps_libgweather,
+- link_with: lib_libgweather,
+- include_directories: root_inc,
+-)
+-
+ if enable_vala
+ gnome.generate_vapi('gweather-3.0',
+ sources: gweather_gir[0],
+@@ -98,11 +100,13 @@ if enable_vala
+ install: true
+ )
+ endif
++endif
+
+ test_cargs = ['-DTEST_SRCDIR="@0@/"'.format(meson.current_source_dir()),
+ '-DSCHEMASDIR="@0@/schemas"'.format(meson.source_root()),
+ '-DSCHEMAS_BUILDDIR="@0@/schemas"'.format(meson.build_root())]
+
++if false
+ executable('test_locations',
+ ['test_locations.c'],
+ c_args: test_cargs,
+@@ -113,6 +117,7 @@ executable('test_locations_utc',
+ c_args: test_cargs,
+ dependencies: libgweather_dep,
+ install: false)
++endif
+
+ exe = executable('test_libgweather',
+ ['test_libgweather.c'],
+@@ -121,6 +126,7 @@ exe = executable('test_libgweather',
+ install: false)
+ test('test_named_timezones', exe)
+
++if false
+ executable('test_metar',
+ ['test_metar.c', gweather_c_sources],
+ c_args: test_cargs,
+@@ -131,3 +137,4 @@ executable('test_sun_moon',
+ c_args: test_cargs,
+ dependencies: libgweather_dep,
+ install: false)
++endif
+diff --git a/meson.build b/meson.build
+index 54a5063..96e5d27 100644
+--- a/meson.build
++++ b/meson.build
+@@ -112,6 +112,10 @@ else
+ enable_vala = enable_vala != 'false'
+ endif
+
++if enable_vala and not get_option('introspection')
++ error('Vala bindings require introspection support')
++endif
++
+ root_inc = include_directories('.')
+
+ subdir('libgweather')
+diff --git a/meson_options.txt b/meson_options.txt
+index 19b2c6a..bf4c517 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -8,3 +8,5 @@ option('enable_vala', type: 'combo', choices : ['true', 'false', 'auto'], value
+ description: 'Install vala bindings')
+ option('gtk_doc', type: 'boolean', value: false,
+ description: 'Whether to generate the API reference')
++option('introspection', type: 'boolean', value: true,
++ description: 'generate GObject Introspection data')
+--
+2.17.0
+