summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-20 12:25:16 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-20 12:54:07 -0700
commit60705b71be0510dc997c221fa9bf3e80146d4e5c (patch)
treef678be24ff1434f143a632f871406db55c1e23d2 /dev-libs/libgweather
parentgui-libs/libhandy: Drop old versions (diff)
downloadgentoo-60705b71be0510dc997c221fa9bf3e80146d4e5c.tar.gz
gentoo-60705b71be0510dc997c221fa9bf3e80146d4e5c.tar.bz2
gentoo-60705b71be0510dc997c221fa9bf3e80146d4e5c.zip
dev-libs/libgweather: Version bump to 4.0.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/Manifest1
-rw-r--r--dev-libs/libgweather/files/4.0.0-autoskip-network-test.patch29
-rw-r--r--dev-libs/libgweather/files/4.0.0-vapigen.patch29
-rw-r--r--dev-libs/libgweather/libgweather-4.0.0.ebuild80
4 files changed, 139 insertions, 0 deletions
diff --git a/dev-libs/libgweather/Manifest b/dev-libs/libgweather/Manifest
index 75a29971b046..b886c39a5164 100644
--- a/dev-libs/libgweather/Manifest
+++ b/dev-libs/libgweather/Manifest
@@ -1 +1,2 @@
+DIST libgweather-4.0.0.tar.xz 4722620 BLAKE2B f2500d065fe9607b740c2f6c87378d5fc86c15951b2880f89c3ac22021d085eed601b645dcf1c9864fe1fa47860aa14ed1ab858263a7634c3b7615231d3ee6d1 SHA512 1441b8996a53b277e9453d3fcf32448800c963f40c32542f9055362bc3188dcf2e706466133d53b3f1b6343dc97b15cf5eabe16b950e7c9451cb79eeef87a9c3
DIST libgweather-40.0.tar.xz 2704404 BLAKE2B 27bc69c350ae91a07307d75b5ea1d03bb251f51bf87d5d54861965b61d7ed825ab708466cbe9d961c4f544b8b17ca6ed37b723c003ce2c1ef020270d6812c61d SHA512 72e295246bf03550039a70bd4bf5b8f06357a6b70e04308c197fba309e406d410a97d128d849d97a29a6a114faa1ef5452e6632870b7ea45223a0c305c228cc1
diff --git a/dev-libs/libgweather/files/4.0.0-autoskip-network-test.patch b/dev-libs/libgweather/files/4.0.0-autoskip-network-test.patch
new file mode 100644
index 000000000000..3f27906de012
--- /dev/null
+++ b/dev-libs/libgweather/files/4.0.0-autoskip-network-test.patch
@@ -0,0 +1,29 @@
+From 87c0d202977c212a6b7fd360ceaa295e422de87d Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 30 Aug 2020 10:35:13 +0300
+Subject: [PATCH] tests: Skip metar tests when METAR_SOURCES couldn't be
+ resolved
+
+---
+ libgweather/tests/metar.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/libgweather/tests/metar.c b/libgweather/tests/metar.c
+index 7d6c7c04..0b3025a2 100644
+--- a/libgweather/tests/metar.c
++++ b/libgweather/tests/metar.c
+@@ -142,6 +142,11 @@ test_metar_weather_stations (void)
+ g_test_message ("SSL/TLS failure, please check your glib-networking installation");
+ g_test_failed ();
+ return;
++ } else if (msg->status_code == SOUP_STATUS_CANT_RESOLVE) {
++ g_test_skip ("Could not resolve " METAR_SOURCES " - network sandboxed?");
++ g_object_unref (session);
++ g_object_unref (msg);
++ return;
+ }
+ #if SOUP_CHECK_VERSION(2, 99, 2)
+ g_assert_no_error (error);
+--
+2.34.1
+
diff --git a/dev-libs/libgweather/files/4.0.0-vapigen.patch b/dev-libs/libgweather/files/4.0.0-vapigen.patch
new file mode 100644
index 000000000000..d5c4ca12623e
--- /dev/null
+++ b/dev-libs/libgweather/files/4.0.0-vapigen.patch
@@ -0,0 +1,29 @@
+https://gitlab.gnome.org/GNOME/libgweather/-/merge_requests/176
+
+From 98b505675f631c1fabbbcbcee2523f8dde8e7e3d Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Sun, 20 Mar 2022 12:19:59 -0700
+Subject: [PATCH] meson: Use dependency() for finding vapigen
+
+This allows the vapigen binary to be chosen by overriding the VAPIGEN
+environment variable.
+---
+ libgweather/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgweather/meson.build b/libgweather/meson.build
+index 08311af4..7148f5ca 100644
+--- a/libgweather/meson.build
++++ b/libgweather/meson.build
+@@ -211,7 +211,7 @@ g_ir_scanner = find_program('g-ir-scanner', required: get_option('introspection'
+ build_gir = get_option('introspection') and g_ir_scanner.found() and not meson.is_cross_build()
+
+ enable_vala = get_option('enable_vala')
+-vapigen = find_program('vapigen', required: enable_vala == 'true')
++vapigen = dependency('vapigen', required: enable_vala == 'true')
+ if enable_vala == 'auto' or enable_vala == 'true'
+ build_vapi = vapigen.found() and get_option('introspection')
+ if enable_vala == 'true' and not build_vapi
+--
+2.34.1
+
diff --git a/dev-libs/libgweather/libgweather-4.0.0.ebuild b/dev-libs/libgweather/libgweather-4.0.0.ebuild
new file mode 100644
index 000000000000..60544f5ea355
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-4.0.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Location and timezone database and weather-lookup library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="4/4-0" # subslot = 4-(libgweather-4 soname suffix)
+
+IUSE="gtk-doc +introspection test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=net-libs/libsoup-2.44:2.4
+ >=dev-libs/libxml2-2.6.0:2
+ sci-geosciences/geocode-glib
+
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gi-docgen-2021.6
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/4.0.0-autoskip-network-test.patch
+ "${FILESDIR}"/4.0.0-vapigen.patch
+)
+
+python_check_deps() {
+ has_version -b "dev-python/pygobject[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use vala enable_vala)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dsoup2=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}