summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 20:57:39 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:20 +0100
commitf6c7b24d68722df3a8be8a74156a78d0846c8b27 (patch)
treea53873eefbeee7058ab04158fd17024d08cfc97e /dev-libs/libhid
parentdev-libs/concurrencykit: drop 0.7.1 (diff)
downloadgentoo-f6c7b24d68722df3a8be8a74156a78d0846c8b27.tar.gz
gentoo-f6c7b24d68722df3a8be8a74156a78d0846c8b27.tar.bz2
gentoo-f6c7b24d68722df3a8be8a74156a78d0846c8b27.zip
dev-libs/libhid: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/libhid')
-rw-r--r--dev-libs/libhid/libhid-0.2.17-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libhid/libhid-0.2.17-r1.ebuild b/dev-libs/libhid/libhid-0.2.17-r1.ebuild
new file mode 100644
index 000000000000..908ad8e00008
--- /dev/null
+++ b/dev-libs/libhid/libhid-0.2.17-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Provides a generic and flexible way to access and interact with USB HID devices"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="doc"
+
+RDEPEND="virtual/libusb:0="
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( app-doc/doxygen )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-man.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ export OS_LDFLAGS="${LDFLAGS}"
+
+ myeconfargs=(
+ "--disable-static"
+ "--disable-swig"
+ "--disable-warnings"
+ "--disable-werror"
+ "$(use_with doc doxygen)"
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/html/.
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}