summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-16 16:29:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-16 16:29:53 +0100
commit3f2bc1711c4a457c3179b22da4491460f7ced19a (patch)
tree84fb13011e28c2463dc26925583dcb87f0a98476 /dev-libs/libical/libical-3.0.9.ebuild
parentdev-php/xdebug: Drop old (diff)
downloadgentoo-3f2bc1711c4a457c3179b22da4491460f7ced19a.tar.gz
gentoo-3f2bc1711c4a457c3179b22da4491460f7ced19a.tar.bz2
gentoo-3f2bc1711c4a457c3179b22da4491460f7ced19a.zip
dev-libs/libical: Fix tests with IUSE=glib
Reported-by: Toralf Förster <toralf@gentoo.org> Thanks-to: Frederik Pfautsch <bugs@fpprogs.de> Closes: https://bugs.gentoo.org/712812 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libical/libical-3.0.9.ebuild')
-rw-r--r--dev-libs/libical/libical-3.0.9.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/libical/libical-3.0.9.ebuild b/dev-libs/libical/libical-3.0.9.ebuild
index 258a7b812641..27c9d5a47a41 100644
--- a/dev-libs/libical/libical-3.0.9.ebuild
+++ b/dev-libs/libical/libical-3.0.9.ebuild
@@ -25,7 +25,10 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
introspection? ( dev-libs/gobject-introspection )
- test? ( ${PYTHON_DEPS} )
+ test? (
+ ${PYTHON_DEPS}
+ glib? ( $(python_gen_any_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]') )
+ )
vala? ( $(vala_depend) )
"
COMMON_DEPEND="
@@ -50,6 +53,10 @@ PATCHES=(
"${FILESDIR}/${PN}-3.0.5-pkgconfig-libdir.patch"
)
+python_check_deps() {
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}