summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2017-10-05 19:02:23 +0200
committerDaniel Pielmeier <billie@gentoo.org>2017-10-05 19:02:23 +0200
commit640037992b2291d085871b7ec379ec76cc7af86b (patch)
tree77120ff7367e745286dbadeb648b0ffb5ec68d8f /dev-libs/libisofs/libisofs-1.4.8.ebuild
parentdev-libs/libburn: Version bump. (diff)
downloadgentoo-640037992b2291d085871b7ec379ec76cc7af86b.tar.gz
gentoo-640037992b2291d085871b7ec379ec76cc7af86b.tar.bz2
gentoo-640037992b2291d085871b7ec379ec76cc7af86b.zip
dev-libs/libisofs: Version bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libisofs/libisofs-1.4.8.ebuild')
-rw-r--r--dev-libs/libisofs/libisofs-1.4.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libisofs/libisofs-1.4.8.ebuild b/dev-libs/libisofs/libisofs-1.4.8.ebuild
new file mode 100644
index 000000000000..fbe5152ed83f
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.4.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ find "${D}" -name '*.la' -delete || die
+}