summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-11-13 21:02:24 +0100
committerDaniel Pielmeier <billie@gentoo.org>2019-11-13 21:02:24 +0100
commitf950a1a929f0638a83255f7cb128eb06dd2c66ba (patch)
tree4ce9198811f6461008a65c953bea723af3d6c683 /dev-libs/libisofs/libisofs-1.5.2.ebuild
parentdev-libs/libburn: Version bump libburn-1.5.2. (diff)
downloadgentoo-f950a1a929f0638a83255f7cb128eb06dd2c66ba.tar.gz
gentoo-f950a1a929f0638a83255f7cb128eb06dd2c66ba.tar.bz2
gentoo-f950a1a929f0638a83255f7cb128eb06dd2c66ba.zip
dev-libs/libisofs: Version bump libisofs-1.5.2.
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'dev-libs/libisofs/libisofs-1.5.2.ebuild')
-rw-r--r--dev-libs/libisofs/libisofs-1.5.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libisofs/libisofs-1.5.2.ebuild b/dev-libs/libisofs/libisofs-1.5.2.ebuild
new file mode 100644
index 000000000000..0d969ee783c8
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ find "${D}" -name '*.la' -delete || die
+}