summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-10-07 16:32:49 +0200
committerDaniel Pielmeier <billie@gentoo.org>2018-10-07 16:32:49 +0200
commitffa1bcff37a0baf323bc7040efad5bfd8693a2b6 (patch)
tree86c28af0b06280a54d3aab48c8a25d2cfd923f41 /dev-libs/libisofs
parentsys-fs/fatsort: Version bump to 1.5.0. Switch to EAPI 7. (diff)
downloadgentoo-ffa1bcff37a0baf323bc7040efad5bfd8693a2b6.tar.gz
gentoo-ffa1bcff37a0baf323bc7040efad5bfd8693a2b6.tar.bz2
gentoo-ffa1bcff37a0baf323bc7040efad5bfd8693a2b6.zip
dev-libs/libisofs: Version bump to 1.5.0. Switch to EAPI 7.
Signed-off-by: Daniel Pielmeier <billie@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libisofs')
-rw-r--r--dev-libs/libisofs/Manifest1
-rw-r--r--dev-libs/libisofs/libisofs-1.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libisofs/Manifest b/dev-libs/libisofs/Manifest
index 7af8bb2589d7..a98f17b3407e 100644
--- a/dev-libs/libisofs/Manifest
+++ b/dev-libs/libisofs/Manifest
@@ -1 +1,2 @@
DIST libisofs-1.4.8.tar.gz 829979 BLAKE2B 78275a8a1c2ed3824d25dcd2eb02675059d102f2f0b93ae469ea18c342bd6c72e79655eb9f3c700539f87ad46bb97b6a3e28950f84a03bf3d9f1fd982c4fc479 SHA512 0c6f505a951a1b7fce63bf63c715e5acb3158c15be2660627d2380771f025ec88bd67a4c2b8c86ef9dbb649a23cb26b826e875e7c87ff46c8bcd13d831fe8bcc
+DIST libisofs-1.5.0.tar.gz 834099 BLAKE2B 57dbdb4173df635d2811c61a0b88e49f617b628909a6f87eeca7715a2c94b25b381860722cd56752cac28993bb314c9b0371ae5c0ca73e37044192f50aa47179 SHA512 1d0bc488c18b95971b7aa89765d7b5772b64d17eadeae9ec52c0f880c6f68acee80ee39b603752a1f9fbe0f35029c27023d5a6710d149a0f568bb396c3dcede8
diff --git a/dev-libs/libisofs/libisofs-1.5.0.ebuild b/dev-libs/libisofs/libisofs-1.5.0.ebuild
new file mode 100644
index 000000000000..6c6df197b20a
--- /dev/null
+++ b/dev-libs/libisofs/libisofs-1.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ acl? ( virtual/acl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable verbose-debug) \
+ $(use_enable acl libacl) \
+ $(use_enable xattr) \
+ $(use_enable zlib) \
+ --disable-libjte \
+ --disable-ldconfig-at-install
+}
+
+src_install() {
+ default
+
+ dodoc Roadmap doc/{*.txt,Tutorial}
+
+ find "${D}" -name '*.la' -delete || die
+}