summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-06-06 19:00:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-06-10 17:32:18 +0200
commit11f43e479d6732a4a54e2d342a0945a55e8ced8e (patch)
treeb1b5be43f6fac36ed4911e223fe1ab330b0d4cf2 /dev-libs/libixion/libixion-0.15.0.ebuild
parentdev-libs/liborcus: Drop 0.15.4 (diff)
downloadgentoo-11f43e479d6732a4a54e2d342a0945a55e8ced8e.tar.gz
gentoo-11f43e479d6732a4a54e2d342a0945a55e8ced8e.tar.bz2
gentoo-11f43e479d6732a4a54e2d342a0945a55e8ced8e.zip
dev-libs/libixion: Drop 0.15.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/libixion/libixion-0.15.0.ebuild')
-rw-r--r--dev-libs/libixion/libixion-0.15.0.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-libs/libixion/libixion-0.15.0.ebuild b/dev-libs/libixion/libixion-0.15.0.ebuild
deleted file mode 100644
index 9d8cd6a883d7..000000000000
--- a/dev-libs/libixion/libixion-0.15.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit autotools python-single-r1
-
-DESCRIPTION="General purpose formula parser & interpreter"
-HOMEPAGE="https://gitlab.com/ixion/ixion"
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
- inherit git-r3
-else
- SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/0.15" # based on SONAME of libixion.so
-IUSE="debug python +threads"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost:=
- dev-util/mdds:1/1.5
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
- dev-libs/spdlog
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-musl-clang.patch" # bug 714018
- "${FILESDIR}/${P}-bashism.patch" # bug 723128
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- $(use_enable debug)
- $(use_enable python)
- $(use_enable threads)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}