summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-11 11:53:41 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-11 12:06:09 +0200
commitb07f8b0b5a03243325bcb38264c21319daac11e0 (patch)
tree23ae2ead9aeac758e74ebcfd2a379cf431e4353b /dev-libs/liblinear/liblinear-230.ebuild
parentdev-vcs/subversion: stable 1.12.2 for hppa, bug #690594 (diff)
downloadgentoo-b07f8b0b5a03243325bcb38264c21319daac11e0.tar.gz
gentoo-b07f8b0b5a03243325bcb38264c21319daac11e0.tar.bz2
gentoo-b07f8b0b5a03243325bcb38264c21319daac11e0.zip
dev-libs/liblinear: Revert "Add IUSE=blas."
In commit 22acd3654a599abcfe5457c157b6e2937a0242ec ("Add IUSE=blas.") I tried to add support for linking against a BLAS implementation as suggested in liblinear's documentation. As so far liblinear does not support any helpers for linking against it as well as a BLAS library in an automated way, enabling USE=blas can result in linking failures in packages that are unaware of the BLAS linkage. Until a pkg-config file or other reliable source for library linkage is provided with liblinear, usage of an external BLAS library cannot be supported. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Fixes: https://bugs.gentoo.org/691926 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/liblinear/liblinear-230.ebuild')
-rw-r--r--dev-libs/liblinear/liblinear-230.ebuild13
1 files changed, 0 insertions, 13 deletions
diff --git a/dev-libs/liblinear/liblinear-230.ebuild b/dev-libs/liblinear/liblinear-230.ebuild
index 00881437e2d5..18f397fed815 100644
--- a/dev-libs/liblinear/liblinear-230.ebuild
+++ b/dev-libs/liblinear/liblinear-230.ebuild
@@ -11,15 +11,6 @@ SRC_URI="https://github.com/cjlin1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
-IUSE="blas"
-
-RDEPEND="
- blas? ( virtual/blas )
-"
-DEPEND="
- ${RDEPEND}
- blas? ( virtual/pkgconfig )
-"
src_prepare() {
default
@@ -35,9 +26,6 @@ src_prepare() {
-e '/^CFLAGS/d;/^CXXFLAGS/d' \
-e 's|$${SHARED_LIB_FLAG}|& $(LDFLAGS)|g' \
Makefile || die
- if use blas; then
- sed -i -e 's:blas/blas.a::g' Makefile || die
- fi
}
src_compile() {
@@ -48,7 +36,6 @@ src_compile() {
CXXFLAGS="${CXXFLAGS} -fPIC" \
AR="$(tc-getAR) rcv" \
RANLIB="$(tc-getRANLIB)" \
- LIBS="$(usex blas "$( $(tc-getPKG_CONFIG) --libs blas )" blas/blas.a)" \
lib all
}