summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-10-09 15:10:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-10-09 16:11:53 +0200
commit3027e7c1fcea0709ad9bebfbe14387ef52837c62 (patch)
tree1d8e8dcf6c4a7bef940da0565ad8201a00c6c405 /dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild
parentnet-im/dianara: revbump (diff)
downloadgentoo-3027e7c1fcea0709ad9bebfbe14387ef52837c62.tar.gz
gentoo-3027e7c1fcea0709ad9bebfbe14387ef52837c62.tar.bz2
gentoo-3027e7c1fcea0709ad9bebfbe14387ef52837c62.zip
dev-libs/liblognorm: Revbump to remove semi-broken pcre functionality
and add an upstream patch. Package-Manager: portage-2.2.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild')
-rw-r--r--dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild b/dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..066a0c4bda91
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-1.1.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF="yes"
+
+inherit autotools-utils
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux"
+IUSE="debug doc static-libs test"
+
+RDEPEND="
+ >=dev-libs/libestr-0.1.3
+ >=dev-libs/json-c-0.11:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}"/respect_CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.1.2-issue_135.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc docs)
+ $(use_enable test testbench)
+ $(use_enable debug)
+ --disable-regexp
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ # When adding new tests via patches we have to make them executable
+ einfo "Adjusting permissions of test scripts ..."
+ find "${S}"/tests -type f -name '*.sh' \! -perm -111 -exec chmod a+x '{}' \; || \
+ die "Failed to adjust test scripts permission"
+
+ emake --jobs 1 check
+}