summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-18 17:17:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-18 17:17:15 +0200
commit34e6f1a81bbc0985980d8481bf533c7e3d2edb82 (patch)
treed1dd44a538af4a8ade4e919c595b643fc40cd6c0 /dev-libs/liblognorm/liblognorm-1.1.2.ebuild
parentdev-php/PEAR-Mail_Mime: Version bump with PHP7 compatibility (diff)
downloadgentoo-34e6f1a81bbc0985980d8481bf533c7e3d2edb82.tar.gz
gentoo-34e6f1a81bbc0985980d8481bf533c7e3d2edb82.tar.bz2
gentoo-34e6f1a81bbc0985980d8481bf533c7e3d2edb82.zip
dev-libs/liblognorm: Version bump.
Thanks to Whissi for providing the ebuild and to Ultrabug for kindly permitting the commit. Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/liblognorm/liblognorm-1.1.2.ebuild')
-rw-r--r--dev-libs/liblognorm/liblognorm-1.1.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/liblognorm/liblognorm-1.1.2.ebuild b/dev-libs/liblognorm/liblognorm-1.1.2.ebuild
new file mode 100644
index 000000000000..5c2807380548
--- /dev/null
+++ b/dev-libs/liblognorm/liblognorm-1.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF="yes"
+
+inherit autotools-utils
+
+DESCRIPTION="Fast samples-based log normalization library"
+HOMEPAGE="http://www.liblognorm.com"
+SRC_URI="http://www.liblognorm.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-linux"
+IUSE="debug doc pcre static-libs test"
+
+RDEPEND="
+ >=dev-libs/json-c-0.11:=
+ >=dev-libs/libestr-0.1.3
+ pcre? ( >=dev-libs/libpcre-8.35 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-python/sphinx-1.2.2 )
+"
+
+DOCS=( ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}"/respect_CFLAGS.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc docs)
+ $(use_enable pcre regexp)
+ $(use_enable test testbench)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake --jobs 1 check
+}